protobufjs has an arbitrary code execution issue
CVE-2026-41242GHSA-xq3m-2v4x-88gg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (protobufjs 8.0.1, 7.5.5, 6.11.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm protobufjs
- Affected
- >= 8.0.0, < 8.0.1>= 7.0.0, < 7.5.5< 6.11.6
- Fixed in
- 6.11.6, 8.0.1, 7.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =0 <7.5.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =0 <7.5.5 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =7.0.0 =0 <6.11.6
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 9.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
- EPSS
- CVE-2026-41242: 0.77% estimated exploitation activity in the next 30 days; percentile 55.79 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary protobufjs could execute generated JavaScript code derived from protobuf schema metadata. When loading a crafted JSON descriptor, schema-controlled type names and type references could reach runtime code generation without sufficient validation. Impact An attacker who can provide a malicious protobuf definition or JSON descriptor to an application may be able to execute arbitrary JavaScript in the context of the process using protobufjs. This requires control over the protobuf schema or descriptor being loaded. Applications that only decode messages using trusted, application-defined schemas are not directly affected by this issue. Preconditions - The application must allow an attacker to control or influence a protobuf definition or JSON descriptor. - The application must load that definition through protobufjs reflection APIs such as descriptor loading. - The affected generated-code path must be reached, for example by performing an operation on the loaded type. Workarounds…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from ghsa record GHSA-xq3m-2v4x-88gg
- Revision 4 · amended ·
Amended from ghsa record GHSA-xq3m-2v4x-88gg
- Revision 3 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 2 · amended ·
Amended from osv record GHSA-xq3m-2v4x-88gg
- Revision 1 · created ·
Published from ghsa record GHSA-xq3m-2v4x-88gg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41242 Advisory: protobufjs has an arbitrary code execution issue IDs: CVE-2026-41242, GHSA-xq3m-2v4x-88gg Record: https://patchnext.com/advisories/cve-2026-41242 (revision 5, source checked 4 Nov 2026, 18:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: protobufjs 8.0.1, 7.5.5, 6.11.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm protobufjs: affected >= 8.0.0, < 8.0.1; >= 7.0.0, < 7.5.5; < 6.11.6; fixed in 6.11.6, 8.0.1, 7.5.5 ## Suggested inspection (read-only) - `npm ls protobufjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on protobufjs. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-xq3m-2v4x-88gg (GitHub-reviewed advisory GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =0 <7.5.5) - Verified: https://osv.dev/vulnerability/GHSA-xq3m-2v4x-88gg (OSV record GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =0 <7.5.5 (fixed)) - Verified: https://github.com/advisories/GHSA-xq3m-2v4x-88gg (GitHub-reviewed advisory GHSA-xq3m-2v4x-88gg lists affected ranges: npm protobufjs >=8.0.0 =7.0.0 =0 <6.11.6) Commands are suggestions: review each one before running it.
Loading voting…