Skip to content

← Actionable
High, CVSS 8.6

Froxlor has an incomplete fix for CVE-2026-30932

CVE-2026-41237GHSA-j6fm-9rfm-j5hx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41237: 0.27% estimated exploitation activity in the next 30 days; percentile 19.16 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The LOC record regex uses \s+ which matches newlines (allowing embedded newlines to pass), TLSA matchingType=0 has no upper bound on hex data length, and all validators return raw input without zone-file escaping. Affected Package - Ecosystem: Other - Package: froxlor - Affected versions: all versions before fix commit b34829262dc3 - Patched versions: = commit b34829262dc3 Severity Medium -- CVSS CWE CWE-74 -- Improper Neutralization of Special Elements in Output Used by a Downstream Component (Injection) Details DNS record content is concatenated directly into bind9 zone files at DnsEntry.php line 83. Before the fix, LOC/RP/SSHFP/TLSA records had no content validation at all, enabling zone file injection via embedded newlines. The fix adds format-specific regexes and field validation but has gaps: the LOC regex's \s+ matches newlines in PHP's PCRE engine, allowing a LOC record with a newline between fields to pass validation but produce multiple lines in the zone file. TLSA…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-j6fm-9rfm-j5hx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41237

Advisory: Froxlor has an incomplete fix for CVE-2026-30932
IDs: CVE-2026-41237, GHSA-j6fm-9rfm-j5hx
Record: https://patchnext.com/advisories/cve-2026-41237 (revision 1, source checked 26 Oct 2026, 14:49 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist froxlor/froxlor: affected <= 2.3.6; fixed in 2.3.7

## Suggested inspection (read-only)
- Packagist froxlor/froxlor: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on froxlor/froxlor.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-j6fm-9rfm-j5hx (GitHub-reviewed advisory GHSA-j6fm-9rfm-j5hx lists affected ranges: Packagist froxlor/froxlor >=0 <=2.3.6)

Commands are suggestions: review each one before running it.

Loading voting…