Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API)
CVE-2026-41229GHSA-gc9w-cc93-rjv8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (froxlor/froxlor 2.3.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist froxlor/froxlor
- Affected
- <= 2.3.5
- Fixed in
- 2.3.6
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gc9w-cc93-rjv8 lists affected ranges: Packagist froxlor/froxlor >=0 <=2.3.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- EPSS
- CVE-2026-41229: 0.48% estimated exploitation activity in the next 30 days; percentile 41.46 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary PhpHelper::parseArrayToString() writes string values into single-quoted PHP string literals without escaping single quotes. When an admin with changeserversettings permission adds or updates a MySQL server via the API, the privilegeduser parameter (which has no input validation) is written unescaped into lib/userdata.inc.php. Since this file is required on every request via Database::getDB(), an attacker can inject arbitrary PHP code that executes as the web server user on every subsequent page load. Details The root cause is in PhpHelper::parseArrayToString() at lib/Froxlor/PhpHelper.php:486: Note that the password key receives special treatment via nowdoc syntax (line 484), which is safe because nowdoc does not interpret any escape sequences or variable interpolation. However, all other string keys — including user, caption, and caFile — are written directly into single-quoted PHP string literals with no escaping. The attack path through MysqlServer::add()…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gc9w-cc93-rjv8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41229 Advisory: Froxlor has a PHP Code Injection via Unescaped Single Quotes in userdata.inc.php Generation (MysqlServer API) IDs: CVE-2026-41229, GHSA-gc9w-cc93-rjv8 Record: https://patchnext.com/advisories/cve-2026-41229 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: froxlor/froxlor 2.3.6. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist froxlor/froxlor: affected <= 2.3.5; fixed in 2.3.6 ## Suggested inspection (read-only) - Packagist froxlor/froxlor: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on froxlor/froxlor. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gc9w-cc93-rjv8 (GitHub-reviewed advisory GHSA-gc9w-cc93-rjv8 lists affected ranges: Packagist froxlor/froxlor >=0 <=2.3.5) Commands are suggestions: review each one before running it.
Loading voting…