@node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes
CVE-2026-41213GHSA-jhm7-29pj-4xvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@node-oauth/oauth2-server 5.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 5.2.1
- Fixed in
- 5.3.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-jhm7-29pj-4xvf lists affected ranges: npm @node-oauth/oauth2-server >=0 <5.3.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jhm7-29pj-4xvf lists affected ranges: npm @node-oauth/oauth2-server >=0 <=5.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-41213: 0.26% estimated exploitation activity in the next 30 days; percentile 17.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The token exchange path accepts RFC7636-invalid codeverifier values (including one-character strings) for S256 PKCE flows. Because short/weak verifiers are accepted and failed verifier attempts do not consume the authorization code, an attacker who intercepts an authorization code can brute-force codeverifier guesses online until token issuance succeeds. Root cause 1. lib/pkce/pkce.js (getHashForCodeChallenge) only checks that verifier is a non-empty string before hashing for S256; it does not enforce RFC7636 ABNF (43..128 unreserved chars). 2. lib/grant-types/authorization-code-grant-type.js compares hash(codeverifier) to stored codeChallenge without validating verifier format/length. 3. In AuthorizationCodeGrantType.handle, authorization code revocation happens after verifier validation. Invalid guesses fail before revoke, so the same code can be retried repeatedly. Steps to Reproduce Setup - PKCE authorization code exists with: - codeChallengeMethod = "S256" -…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-jhm7-29pj-4xvf
- Revision 1 · created ·
Published from osv record GHSA-jhm7-29pj-4xvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41213 Advisory: @node-oauth/oauth2-server: PKCE code_verifier ABNF not enforced in token exchange allows brute-force redemption of intercepted authorization codes IDs: CVE-2026-41213, GHSA-jhm7-29pj-4xvf Record: https://patchnext.com/advisories/cve-2026-41213 (revision 2, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @node-oauth/oauth2-server 5.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @node-oauth/oauth2-server: affected <= 5.2.1; fixed in 5.3.0 ## Suggested inspection (read-only) - `npm ls @node-oauth/oauth2-server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @node-oauth/oauth2-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-jhm7-29pj-4xvf (OSV record GHSA-jhm7-29pj-4xvf lists affected ranges: npm @node-oauth/oauth2-server >=0 <5.3.0 (fixed)) - Verified: https://github.com/advisories/GHSA-jhm7-29pj-4xvf (GitHub-reviewed advisory GHSA-jhm7-29pj-4xvf lists affected ranges: npm @node-oauth/oauth2-server >=0 <=5.2.1) Commands are suggestions: review each one before running it.
Loading voting…