Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution
CVE-2026-41208GHSA-265w-rf2w-cjh4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@paperclipai/server 2026.416.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- < 2026.416.0
- Fixed in
- 2026.416.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-265w-rf2w-cjh4 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-265w-rf2w-cjh4 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-41208: 0.59% estimated exploitation activity in the next 30 days; percentile 48.29 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary Paperclip contains a privilege escalation vulnerability that allows an attacker with an Agent API key to execute arbitrary OS commands on the Paperclip server host. An attacker with an agent credential can escalate privileges from the agent runtime to the Paperclip server host. The vulnerability occurs because agents are allowed to update their own adapterConfig via the /agents/:id API endpoint. The configuration field adapterConfig.workspaceStrategy.provisionCommand is later executed by the server runtime using: As a result, an attacker controlling an agent credential can inject arbitrary shell commands which are executed by the Paperclip server during workspace provisioning. This breaks the intended trust boundary between agent runtime configuration and server host execution, allowing a compromised or malicious agent to escalate privileges and run commands on the host system. This vulnerability allows remote code execution on the server host. Details Rootcause Agent…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-265w-rf2w-cjh4
- Revision 1 · created ·
Published from osv record GHSA-265w-rf2w-cjh4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41208 Advisory: Paperclip: Privilege Escalation via Agent-Controlled workspaceStrategy.provisionCommand Leading to OS Command Execution IDs: CVE-2026-41208, GHSA-265w-rf2w-cjh4 Record: https://patchnext.com/advisories/cve-2026-41208 (revision 2, source checked 26 Oct 2026, 12:50 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @paperclipai/server 2026.416.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @paperclipai/server: affected < 2026.416.0; fixed in 2026.416.0 ## Suggested inspection (read-only) - `npm ls @paperclipai/server --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @paperclipai/server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-265w-rf2w-cjh4 (OSV record GHSA-265w-rf2w-cjh4 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0 (fixed)) - Verified: https://github.com/advisories/GHSA-265w-rf2w-cjh4 (GitHub-reviewed advisory GHSA-265w-rf2w-cjh4 lists affected ranges: npm @paperclipai/server >=0 <2026.416.0) Commands are suggestions: review each one before running it.
Loading voting…