Skip to content

← Actionable
Medium, CVSS 6.9amended

PySpector has a Plugin Code Execution Bypass via Incomplete Static Analysis in PluginSecurity.validate_plugin_code

CVE-2026-41206GHSA-vp22-38m5-r39r

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (pyspector 0.1.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41206: 0.18% estimated exploitation activity in the next 30 days; percentile 8.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The plugin security validator in PySpector uses AST-based static analysis to prevent dangerous code from being loaded as plugins. The blocklist implemented in PluginSecurity.validateplugincode is incomplete and can be bypassed using several Python constructs that are not checked. An attacker who can supply a plugin file can achieve arbitrary code execution within the PySpector process when that plugin is installed and executed. Details The validator maintains a set called fatalcalls that enumerates explicitly forbidden function names and attribute access patterns such as eval, exec, os.system, and subprocess.Popen. However, this approach relies on an exhaustive blocklist of known-dangerous identifiers, which is inherently incomplete. The following bypass techniques are not detected by the current implementation: importlib.importmodule is not in fatalcalls and is not treated as a dangerous module, so it can be used to load os, subprocess, or any other module at runtime without…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vp22-38m5-r39r

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vp22-38m5-r39r

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41206

Advisory: PySpector has a Plugin Code Execution Bypass via Incomplete Static Analysis in PluginSecurity.validate_plugin_code
IDs: CVE-2026-41206, GHSA-vp22-38m5-r39r
Record: https://patchnext.com/advisories/cve-2026-41206 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: pyspector 0.1.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI pyspector: affected <= 0.1.7; fixed in 0.1.8

## Suggested inspection (read-only)
- `python -m pip show pyspector`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on pyspector.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vp22-38m5-r39r (OSV record GHSA-vp22-38m5-r39r lists affected ranges: PyPI pyspector >=0 <0.1.8 (fixed))
- Verified: https://github.com/advisories/GHSA-vp22-38m5-r39r (GitHub-reviewed advisory GHSA-vp22-38m5-r39r lists affected ranges: PyPI pyspector >=0 <=0.1.7)

Commands are suggestions: review each one before running it.

Loading voting…