CI4MS: Backup Management Full Account Takeover for All Roles & Privilege Escalation via Stored DOM Blind XSS
CVE-2026-41201GHSA-qxpq-82f3-xj47
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ci4-cms-erp/ci4ms 0.31.5.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist ci4-cms-erp/ci4ms
- Affected
- < 0.31.5.0
- Fixed in
- 0.31.5.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qxpq-82f3-xj47 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <0.31.5.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.8 · CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:U/C:H/I:H/A:H
- EPSS
- CVE-2026-41201: 0.33% estimated exploitation activity in the next 30 days; percentile 26.28 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
An attacker can achieve Full Account Takeover and Privilege Escalation via Stored DOM XSS in the backup module's filename field, which is manipulated through an SQL file that tampers with the filename field to contain a hidden XSS payload.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qxpq-82f3-xj47
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41201 Advisory: CI4MS: Backup Management Full Account Takeover for All Roles & Privilege Escalation via Stored DOM Blind XSS IDs: CVE-2026-41201, GHSA-qxpq-82f3-xj47 Record: https://patchnext.com/advisories/cve-2026-41201 (revision 1, source checked 26 Oct 2026, 14:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ci4-cms-erp/ci4ms 0.31.5.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist ci4-cms-erp/ci4ms: affected < 0.31.5.0; fixed in 0.31.5.0 ## Suggested inspection (read-only) - Packagist ci4-cms-erp/ci4ms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ci4-cms-erp/ci4ms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qxpq-82f3-xj47 (GitHub-reviewed advisory GHSA-qxpq-82f3-xj47 lists affected ranges: Packagist ci4-cms-erp/ci4ms >=0 <0.31.5.0) Commands are suggestions: review each one before running it.
Loading voting…