Skip to content

← Actionable
Medium, CVSS 6.0

Calico Inserts Sensitive Information into Log File

CVE-2026-41184GHSA-9p7w-w5q6-mxj3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/projectcalico/calico 3.31.6, 1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Go github.com/projectcalico/calico

    Affected
    >= 2.0.0, < 3.31.6< 1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f
    Fixed in
    1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f, 3.31.6

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-9p7w-w5q6-mxj3 lists affected ranges: Go github.com/projectcalico/calico >=2.0.0 =0 <1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.0 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:L/SI:L/SA:L · score source
EPSS
  • CVE-2026-41184: 0.50% estimated exploitation activity in the next 30 days; percentile 43.15 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Calico, the install-cni init container logs the rendered CNI configuration to standard output. When the configuration template uses the SERVICEACCOUNTTOKEN placeholder (Canal/Flannel-Calico deployments), the installer substitutes the live Kubernetes ServiceAccount bearer token before logging, exposing the token to any authenticated user with pods/log permission in the namespace with calico-node. The token holds patch privileges on pods/status, enabling annotation-based attacks against cluster workloads. The default kubeconfig-based authentication path is not affected. This is a direct regression of TTA-2018-001.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9p7w-w5q6-mxj3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41184

Advisory: Calico Inserts Sensitive Information into Log File
IDs: CVE-2026-41184, GHSA-9p7w-w5q6-mxj3
Record: https://patchnext.com/advisories/cve-2026-41184 (revision 1, source checked 26 Oct 2026, 15:24 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/projectcalico/calico 3.31.6, 1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/projectcalico/calico: affected >= 2.0.0, < 3.31.6; < 1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f; fixed in 1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f, 3.31.6

## Suggested inspection (read-only)
- Go github.com/projectcalico/calico: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/projectcalico/calico.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9p7w-w5q6-mxj3 (GitHub-reviewed advisory GHSA-9p7w-w5q6-mxj3 lists affected ranges: Go github.com/projectcalico/calico >=2.0.0 =0 <1.11.0-cni-plugin.0.20260417001138-cd73bc2cea0f)

Commands are suggestions: review each one before running it.

Loading voting…