Statamic: Unsafe method invocation via query value resolution allows data destruction
CVE-2026-41175GHSA-4jjr-vmv7-wh4w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (statamic/cms 6.13.0, 5.73.20), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist statamic/cms
- Affected
- < 5.73.20>= 6.0.0-alpha.1, < 6.13.0
- Fixed in
- 6.13.0, 5.73.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-4jjr-vmv7-wh4w lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.13.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:H
- EPSS
- CVE-2026-41175: 0.30% estimated exploitation activity in the next 30 days; percentile 23.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Manipulating query parameters on Control Panel and REST API endpoints, or arguments in GraphQL queries, could result in the loss of content, assets, and user accounts. The Control Panel requires authentication with minimal permissions in order to exploit. e.g. "view entries" permission to delete entries, or "view users" permission to delete users, etc. The REST and GraphQL API exploits do not require any permissions, however neither are enabled by default. In order to be exploited, they would need to be explicitly enabled with no authentication configured, and the specific resources enabled too. Sites that enable the REST or GraphQL API without authentication should treat patching as critical priority. Patches This has been fixed in 5.73.20 and 6.13.0.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-4jjr-vmv7-wh4w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41175 Advisory: Statamic: Unsafe method invocation via query value resolution allows data destruction IDs: CVE-2026-41175, GHSA-4jjr-vmv7-wh4w Record: https://patchnext.com/advisories/cve-2026-41175 (revision 1, source checked 26 Oct 2026, 14:39 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: statamic/cms 6.13.0, 5.73.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist statamic/cms: affected < 5.73.20; >= 6.0.0-alpha.1, < 6.13.0; fixed in 6.13.0, 5.73.20 ## Suggested inspection (read-only) - Packagist statamic/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on statamic/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-4jjr-vmv7-wh4w (GitHub-reviewed advisory GHSA-4jjr-vmv7-wh4w lists affected ranges: Packagist statamic/cms >=0 =6.0.0-alpha.1 <6.13.0) Commands are suggestions: review each one before running it.
Loading voting…