OpenRemote has Improper Access Control via updateUserRealmRoles function
CVE-2026-41166GHSA-49vv-25qx-mg44
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.openremote:openremote-manager 1.22.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven io.openremote:openremote-manager
- Affected
- < 1.22.1
- Fixed in
- 1.22.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-49vv-25qx-mg44 lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.22.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.0 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:H/A:L
- EPSS
- CVE-2026-41166: 0.29% estimated exploitation activity in the next 30 days; percentile 21.11 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A user who has write:admin in one Keycloak realm can call the Manager API to update Keycloak realm roles for users in another realm, including master. The handler uses the {realm} path segment when talking to the identity provider but does not check that the caller may administer that realm. This could result in a privilege escalation to master realm administrator if the attacker controls any user in master realm. Details In manager/src/main/java/org/openremote/manager/security/UserResourceImpl.java, there is no check to validate if the caller should be able to administer a realm they're trying to update. PoC 1. Create a new Keycloak realm other than master. Add a user and grant that user the OpenRemote client role write:admin. Remember the realm name (call it NEWREALM). 2. In Keycloak realm master, pick a low-privilege user (no admin realm role). Copy that user’s UUID (<master-user-uuid). 3. Authenticate as the user from step 1 and obtain a Bearer access token (<token) for…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-49vv-25qx-mg44
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41166 Advisory: OpenRemote has Improper Access Control via updateUserRealmRoles function IDs: CVE-2026-41166, GHSA-49vv-25qx-mg44 Record: https://patchnext.com/advisories/cve-2026-41166 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: io.openremote:openremote-manager 1.22.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven io.openremote:openremote-manager: affected < 1.22.1; fixed in 1.22.1 ## Suggested inspection (read-only) - Maven io.openremote:openremote-manager: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on io.openremote:openremote-manager. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-49vv-25qx-mg44 (GitHub-reviewed advisory GHSA-49vv-25qx-mg44 lists affected ranges: Maven io.openremote:openremote-manager >=0 <1.22.1) Commands are suggestions: review each one before running it.
Loading voting…