Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS
CVE-2026-41150GHSA-6m6c-36f7-fhxh
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (mermaid 11.15.0, 10.9.6), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm mermaid
- Affected
- >= 11.0.0-alpha.1, <= 11.14.0<= 10.9.5
- Fixed in
- 11.15.0, 10.9.6
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-6m6c-36f7-fhxh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.6 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6m6c-36f7-fhxh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <=10.9.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 5.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:L · score source
- EPSS
- CVE-2026-41150: 0.38% estimated exploitation activity in the next 30 days; percentile 32.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Mermaid v11.14.0 and earlier are vulnerable to a denial-of-service attack when rendering gantt charts, if they use the excludes attribute to exclude all dates. Example: mermaid.parse is unaffected, unless you then call the ganttDb.getTasks() (which is called when rendering a diagram). Patches This has been patched in: - v11.15.0 (see faafb5d49106dd32c367f3882505f2dd625aa30e) - v10.9.6 (see a59ea56174712ee5430dfd5bc877cb5151f501a6) Workarounds There are no workarounds available without updating to a newer version of mermaid.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-6m6c-36f7-fhxh
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-6m6c-36f7-fhxh
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41150 Advisory: Mermaid Gantt Charts are vulnerable to an Infinite Loop DoS IDs: CVE-2026-41150, GHSA-6m6c-36f7-fhxh Record: https://patchnext.com/advisories/cve-2026-41150 (revision 3, source checked 26 Oct 2026, 12:53 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: mermaid 11.15.0, 10.9.6. A vendor fix does not mean a deployment is fixed. ## Affected components - npm mermaid: affected >= 11.0.0-alpha.1, <= 11.14.0; <= 10.9.5; fixed in 11.15.0, 10.9.6 ## Suggested inspection (read-only) - `npm ls mermaid --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on mermaid. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-6m6c-36f7-fhxh (OSV record GHSA-6m6c-36f7-fhxh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <10.9.6 (fixed)) - Verified: https://github.com/advisories/GHSA-6m6c-36f7-fhxh (GitHub-reviewed advisory GHSA-6m6c-36f7-fhxh lists affected ranges: npm mermaid >=11.0.0-alpha.1 =0 <=10.9.5) Commands are suggestions: review each one before running it.
Loading voting…