Skip to content

← Actionable
High, CVSS 8.8

YesWiki vulnerable to authenticated SQL Injection via id_fiche in EntryManager::formatDataBeforeSave()

CVE-2026-41143GHSA-f58v-p6j9-24c2

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (yeswiki/yeswiki 4.6.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41143: 0.34% estimated exploitation activity in the next 30 days; percentile 27.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Vulnerability Details YesWiki bazar module contains a SQL injection vulnerability in tools/bazar/services/EntryManager.php at line 704. The $data['idfiche'] value (sourced from $POST['idfiche']) is concatenated directly into a raw SQL query without any sanitization or parameterization. Vulnerable Code (EntryManager.php:704): Attack Path: 1. Attacker authenticates as any user (route requires acl:{"+"}) 2. POST /api/entries/{formId} with idfiche=' OR SLEEP(3) OR ' 3. ApiController::createEntry() checks isEntry($POST['idfiche']) → false (not existing entry) → calls create() 4. create() → formatDataBeforeSave() → SQL injection at line 704 dbService-loadSingle() passes raw string to mysqliquery() with no escaping. The escape() method exists but is NOT called here. Docker PoC confirmation: - Normal query: SELECT MIN(time) as firsttime FROM wikipages WHERE tag='TestEntry' → 2024-01-01 00:00:00 - Injected: WHERE tag='' OR SLEEP(3) OR '' → elapsed: 3.00s (SLEEP confirmed) - Time-based blind…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-f58v-p6j9-24c2

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41143

Advisory: YesWiki vulnerable to authenticated SQL Injection via id_fiche in EntryManager::formatDataBeforeSave()
IDs: CVE-2026-41143, GHSA-f58v-p6j9-24c2
Record: https://patchnext.com/advisories/cve-2026-41143 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: yeswiki/yeswiki 4.6.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist yeswiki/yeswiki: affected <= 4.6.0; fixed in 4.6.1

## Suggested inspection (read-only)
- Packagist yeswiki/yeswiki: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on yeswiki/yeswiki.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-f58v-p6j9-24c2 (GitHub-reviewed advisory GHSA-f58v-p6j9-24c2 lists affected ranges: Packagist yeswiki/yeswiki >=0 <=4.6.0)

Commands are suggestions: review each one before running it.

Loading voting…