Skip to content

← Actionable
High, CVSS 8.8

mathjs Allows Improperly Controlled Modification of Dynamically-Determined Object Attributes

CVE-2026-41139GHSA-jvff-x2qm-6286

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mathjs 15.2.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm mathjs

    Affected
    >= 13.1.0, < 15.2.0
    Fixed in
    15.2.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41139: 0.58% estimated exploitation activity in the next 30 days; percentile 47.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact This security vulnerability allowed executing arbitrary JavaScript via the expression parser of mathjs. You can be affected when you have an application where users can evaluate arbitrary expressions using the mathjs expression parser.

Patches The issue was introduced in mathjs `v13.1.0`, and patched in mathjs `v15.2.0`.

Workarounds There is no workaround without upgrading to `v15.2.0`.

References You can find out more via the commit fixing this issue: https://github.com/josdejong/mathjs/commit/24d5ee7e25e85d49619b09122f055db4139bc057 (part of PR https://github.com/josdejong/mathjs/pull/3656).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from osv record GHSA-jvff-x2qm-6286

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41139

Advisory: mathjs Allows Improperly Controlled Modification of Dynamically-Determined Object Attributes
IDs: CVE-2026-41139, GHSA-jvff-x2qm-6286
Record: https://patchnext.com/advisories/cve-2026-41139 (revision 1, source checked 24 Oct 2026, 04:13 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mathjs 15.2.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm mathjs: affected >= 13.1.0, < 15.2.0; fixed in 15.2.0

## Suggested inspection (read-only)
- `npm ls mathjs --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mathjs.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-jvff-x2qm-6286 (OSV record GHSA-jvff-x2qm-6286 lists affected ranges: npm mathjs >=13.1.0 <15.2.0 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…