Skip to content

← Actionable
High, CVSS 7.3

Kiota: Code Generation Literal Injection

CVE-2026-41134GHSA-2hx3-vp6r-mg3f

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (microsoft.openapi.kiota 1.31.1, 1.29.1; microsoft.openapi.kiota.builder 1.31.1, 1.29.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
7.3 · CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2026-41134: 0.42% estimated exploitation activity in the next 30 days; percentile 36.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

CVE Advisory (CVE-2026-41134): Code Generation Literal Injection in Kiota Summary Kiota versions prior to 1.29.1 and 1.31.1 are affected by a code-generation literal injection vulnerability in multiple writer sinks (for example: serialization/deserialization keys, path/query parameter mappings, URL template metadata, enum/property metadata, and default value emission). When malicious values from an OpenAPI description are emitted into generated source without context-appropriate escaping, an attacker can break out of string literals and inject additional code into generated clients. Impact and Preconditions This issue is only practically exploitable when: 1. the OpenAPI description used for generation is from an untrusted source, or 2. a normally trusted OpenAPI description has been compromised/tampered with. If you only generate from trusted, integrity-protected API descriptions, risk is significantly reduced. Affected Versions - Affected: all versions < 1.29.1 and = 1.30.0, <…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-2hx3-vp6r-mg3f

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41134

Advisory: Kiota: Code Generation Literal Injection
IDs: CVE-2026-41134, GHSA-2hx3-vp6r-mg3f
Record: https://patchnext.com/advisories/cve-2026-41134 (revision 1, source checked 26 Oct 2026, 17:05 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: microsoft.openapi.kiota 1.31.1, 1.29.1; microsoft.openapi.kiota.builder 1.31.1, 1.29.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet microsoft.openapi.kiota: affected >= 1.30.0, < 1.31.1; < 1.29.1; fixed in 1.31.1, 1.29.1
- NuGet microsoft.openapi.kiota.builder: affected >= 1.30.0, < 1.31.1; < 1.29.1; fixed in 1.31.1, 1.29.1

## Suggested inspection (read-only)
- NuGet microsoft.openapi.kiota: check the installed version with your package manager.
- NuGet microsoft.openapi.kiota.builder: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on microsoft.openapi.kiota, microsoft.openapi.kiota.builder.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-2hx3-vp6r-mg3f (GitHub-reviewed advisory GHSA-2hx3-vp6r-mg3f lists affected ranges: NuGet microsoft.openapi.kiota >=1.30.0 =0 =1.30.0 =0 <1.29.1)

Commands are suggestions: review each one before running it.

Loading voting…