Skip to content

← Actionable
Critical, CVSS 10.0

openvpn-auth-oauth2 returns FUNC_SUCCESS on client-deny, allowing unauthenticated VPN access

CVE-2026-41070GHSA-246w-jgmq-88fg

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/jkroepke/openvpn-auth-oauth2 1.27.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
10.0 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-41070: 0.44% estimated exploitation activity in the next 30 days; percentile 38.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary When openvpn-auth-oauth2 is deployed in the experimental plugin mode (shared library loaded by OpenVPN via the plugin directive), clients that do not support WebAuth/SSO (e.g., the openvpn CLI on Linux) are incorrectly admitted to the VPN despite being denied by the authentication logic. The default management-interface mode is not affected because it does not use the OpenVPN plugin return-code mechanism. Impact Authentication bypass — any VPN client that does not advertise WebAuth/SSO support (IVSSO=webauth) is granted full network access without completing OIDC authentication. This affects only deployments running the experimental plugin mode in versions 1.26.3 through 1.27.2. The default and recommended deployment via the management interface is not affected. An unauthenticated attacker can connect to the OpenVPN server using any standard OpenVPN client that does not support webauth (e.g., the Linux openvpn CLI). The plugin correctly issues a client-deny command via the…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-246w-jgmq-88fg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41070

Advisory: openvpn-auth-oauth2 returns FUNC_SUCCESS on client-deny, allowing unauthenticated VPN access
IDs: CVE-2026-41070, GHSA-246w-jgmq-88fg
Record: https://patchnext.com/advisories/cve-2026-41070 (revision 1, source checked 26 Oct 2026, 15:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 10.0)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/jkroepke/openvpn-auth-oauth2 1.27.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/jkroepke/openvpn-auth-oauth2: affected >= 1.26.3, < 1.27.3; fixed in 1.27.3

## Suggested inspection (read-only)
- Go github.com/jkroepke/openvpn-auth-oauth2: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/jkroepke/openvpn-auth-oauth2.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-246w-jgmq-88fg (GitHub-reviewed advisory GHSA-246w-jgmq-88fg lists affected ranges: Go github.com/jkroepke/openvpn-auth-oauth2 >=1.26.3 <1.27.3)

Commands are suggestions: review each one before running it.

Loading voting…