lxml: Default configuration of iterparse() and ETCompatXMLParser() allows XXE to local files
CVE-2026-41066GHSA-vfmq-68hx-4jfw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (lxml 6.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI lxml
- Affected
- < 6.1.0
- Fixed in
- 6.1.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-vfmq-68hx-4jfw lists affected ranges: PyPI lxml >=0 <6.1.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vfmq-68hx-4jfw lists affected ranges: PyPI lxml >=0 <6.1.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-41066: 0.32% estimated exploitation activity in the next 30 days; percentile 25.56 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Using either of the two parsers in the default configuration (with resolveentities=True) allows untrusted XML input to read local files. Patches lxml 6.1.0 changes the default to resolveentities='internal', thus disallowing local file access by default. Workarounds Setting the resolveentities option explicitly to resolveentities='internal' or resolveentities=False disables the local file access. Resources Original report: https://bugs.launchpad.net/lxml/+bug/2146291 The default option was changed to resolveentities='internal' for the normal XML and HTML parsers in lxml 5.0. The default was not changed for iterparse() and ETCompatXMLParser() at the time. lxml 6.1 makes the safe option the default for all parsers.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-vfmq-68hx-4jfw
- Revision 1 · created ·
Published from osv record GHSA-vfmq-68hx-4jfw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41066 Advisory: lxml: Default configuration of iterparse() and ETCompatXMLParser() allows XXE to local files IDs: CVE-2026-41066, GHSA-vfmq-68hx-4jfw Record: https://patchnext.com/advisories/cve-2026-41066 (revision 2, source checked 26 Oct 2026, 13:44 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: lxml 6.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI lxml: affected < 6.1.0; fixed in 6.1.0 ## Suggested inspection (read-only) - `python -m pip show lxml`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on lxml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-vfmq-68hx-4jfw (OSV record GHSA-vfmq-68hx-4jfw lists affected ranges: PyPI lxml >=0 <6.1.0 (fixed)) - Verified: https://github.com/advisories/GHSA-vfmq-68hx-4jfw (GitHub-reviewed advisory GHSA-vfmq-68hx-4jfw lists affected ranges: PyPI lxml >=0 <6.1.0) Commands are suggestions: review each one before running it.
Loading voting…