OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex
CVE-2026-41059GHSA-pxq7-h93f-9jrg
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/oauth2-proxy/oauth2-proxy/v7 7.15.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Go github.com/oauth2-proxy/oauth2-proxy/v7
- Affected
- >= 7.5.0, < 7.15.2
- Fixed in
- 7.15.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pxq7-h93f-9jrg lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=7.5.0 <7.15.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-41059: 0.27% estimated exploitation activity in the next 30 days; percentile 19.96 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact A configuration-dependent authentication bypass exists in OAuth2 Proxy. Deployments are affected when all of the following are true: Use of skipauthroutes or the legacy skipauthregex Use of patterns that can be widened by attacker-controlled suffixes, such as ^/foo/./bar$ causing potential exposure of /foo/secret Protected upstream applications that interpret
as a fragment delimiter or otherwise route the request to the protected base path In deployments that rely on these settings, an unauthenticated attacker can send a crafted request containing a number sign in the path, including the browser-safe encoded form %23, so that OAuth2 Proxy matches a public allowlist rule while the backend serves a protected resource. Deployments that do not use these skip-auth options, or that only allow exact public paths with tightly scoped method and path rules, ARE NOT affected. Patches A fix has been implemented to normalize request paths more conservatively before skip-auth matching so…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pxq7-h93f-9jrg
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41059 Advisory: OAuth2 Proxy has an Authentication Bypass via Fragment Confusion in skip_auth_routes and skip_auth_regex IDs: CVE-2026-41059, GHSA-pxq7-h93f-9jrg Record: https://patchnext.com/advisories/cve-2026-41059 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/oauth2-proxy/oauth2-proxy/v7 7.15.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/oauth2-proxy/oauth2-proxy/v7: affected >= 7.5.0, < 7.15.2; fixed in 7.15.2 ## Suggested inspection (read-only) - Go github.com/oauth2-proxy/oauth2-proxy/v7: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/oauth2-proxy/oauth2-proxy/v7. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pxq7-h93f-9jrg (GitHub-reviewed advisory GHSA-pxq7-h93f-9jrg lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=7.5.0 <7.15.2) Commands are suggestions: review each one before running it.
Loading voting…