Skip to content

← Actionable
High, CVSS 8.8

Apache ActiveMQ Vulnerable to Code Injection

CVE-2026-41044GHSA-mr6m-xj7v-3cv3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.activemq:activemq-broker 6.2.5, 5.19.6; org.apache.activemq:apache-activemq 6.2.5, 5.19.6; org.apache.activemq:activemq-all 6.2.5, 5.19.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-41044: 0.98% estimated exploitation activity in the next 30 days; percentile 62.27 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Improper Input Validation, Improper Control of Generation of Code ('Code Injection') vulnerability in Apache ActiveMQ, Apache ActiveMQ Broker, Apache ActiveMQ All. An authenticated attacker can use the admin web console page to construct a malicious broker name that bypasses name validation to include an xbean binding that can be later used by a VM transport to load a remote Spring XML application. The attacker can then use the DestinationView mbean to send a message to trigger a VM transport creation that will reference this malicious broker name which can lead to loading the malicious Spring XML context file. Because Spring's ResourceXmlApplicationContext instantiates all singleton beans before the BrokerService validates the configuration, arbitrary code execution occurs on the broker's JVM through bean factory methods such as Runtime.exec(). This issue affects Apache ActiveMQ: before 5.19.6, from 6.0.0 before 6.2.5; Apache ActiveMQ Broker: before 5.19.6, from 6.0.0 before 6.2.5;…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-mr6m-xj7v-3cv3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41044

Advisory: Apache ActiveMQ Vulnerable to Code Injection
IDs: CVE-2026-41044, GHSA-mr6m-xj7v-3cv3
Record: https://patchnext.com/advisories/cve-2026-41044 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.activemq:activemq-broker 6.2.5, 5.19.6; org.apache.activemq:apache-activemq 6.2.5, 5.19.6; org.apache.activemq:activemq-all 6.2.5, 5.19.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.activemq:activemq-broker: affected < 5.19.6; >= 6.0.0, < 6.2.5; fixed in 6.2.5, 5.19.6
- Maven org.apache.activemq:apache-activemq: affected < 5.19.6; >= 6.0.0, < 6.2.5; fixed in 6.2.5, 5.19.6
- Maven org.apache.activemq:activemq-all: affected < 5.19.6; >= 6.0.0, < 6.2.5; fixed in 6.2.5, 5.19.6

## Suggested inspection (read-only)
- Maven org.apache.activemq:activemq-broker: check the installed version with your package manager.
- Maven org.apache.activemq:apache-activemq: check the installed version with your package manager.
- Maven org.apache.activemq:activemq-all: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.activemq:activemq-broker, org.apache.activemq:apache-activemq, org.apache.activemq:activemq-all.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-mr6m-xj7v-3cv3 (GitHub-reviewed advisory GHSA-mr6m-xj7v-3cv3 lists affected ranges: Maven org.apache.activemq:apache-activemq >=0 =6.0.0 =0 =6.0.0 =0 =6.0.0 <6.2.5)

Commands are suggestions: review each one before running it.

Loading voting…