Skip to content

← Actionable
Medium, CVSS 5.9amended

Apache Airflow has a Sensitive Cookie in HTTPS Session Without 'Secure' Attribute

CVE-2026-41017GHSA-95v7-h9j5-gvjr

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow 3.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-41017: 0.35% estimated exploitation activity in the next 30 days; percentile 28.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Airflow's JWTRefreshMiddleware set the JWT auth cookie without the Secure flag, so deployments running the Airflow API server behind an HTTPS-terminating reverse proxy (e.g. nginx / Envoy / a managed load balancer that terminates TLS and forwards plaintext to the API server, the default cloud-native topology) would have the user's session JWT replayed over any cleartext HTTP request to the same host. A network-positioned attacker (Wi-Fi MITM, hostile LAN, captive-portal proxy) could induce a logged-in user's browser to issue an HTTP request to the deployment's hostname and capture the JWT cookie out of that request, then replay it against the authenticated API. Affects deployments where the Airflow API server is reached through a TLS-terminating proxy and the cookie's secure-by-default protection is load-bearing for session integrity. Users are advised to upgrade to apache-airflow 3.2.2 or later.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-95v7-h9j5-gvjr

  2. Revision 1 · created ·

    Published from osv record GHSA-95v7-h9j5-gvjr

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41017

Advisory: Apache Airflow has a Sensitive Cookie in HTTPS Session Without 'Secure' Attribute
IDs: CVE-2026-41017, GHSA-95v7-h9j5-gvjr
Record: https://patchnext.com/advisories/cve-2026-41017 (revision 2, source checked 26 Oct 2026, 13:46 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: apache-airflow 3.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI apache-airflow: affected >= 3.0.0, < 3.2.2; fixed in 3.2.2

## Suggested inspection (read-only)
- `python -m pip show apache-airflow`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on apache-airflow.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-95v7-h9j5-gvjr (OSV record GHSA-95v7-h9j5-gvjr lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-95v7-h9j5-gvjr (GitHub-reviewed advisory GHSA-95v7-h9j5-gvjr lists affected ranges: PyPI apache-airflow >=3.0.0 <3.2.2)

Commands are suggestions: review each one before running it.

Loading voting…