apache-airflow-providers-smtp: No certificate validation on SMTP STARTTLS connections in SMTP provider
CVE-2026-41016GHSA-x8mh-94wc-33gv
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-smtp 3.0.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-smtp
- Affected
- >= 2.0.0, < 3.0.0
- Fixed in
- 3.0.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x8mh-94wc-33gv lists affected ranges: PyPI apache-airflow-providers-smtp >=2.0.0 <3.0.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x8mh-94wc-33gv lists affected ranges: PyPI apache-airflow-providers-smtp >=2.0.0 <3.0.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.9 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
- EPSS
- CVE-2026-41016: 0.27% estimated exploitation activity in the next 30 days; percentile 18.99 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Airflow's SMTP provider SmtpHook called Python's smtplib.SMTP.starttls() without an SSL context, so no certificate validation was performed on the TLS upgrade. A man-in-the-middle between the Airflow worker and the SMTP server could present a self-signed certificate, complete the STARTTLS upgrade, and capture the SMTP credentials sent during the subsequent login() call. Users are advised to upgrade to the apache-airflow-providers-smtp version that contains the fix.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-x8mh-94wc-33gv
- Revision 1 · created ·
Published from osv record GHSA-x8mh-94wc-33gv
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-41016 Advisory: apache-airflow-providers-smtp: No certificate validation on SMTP STARTTLS connections in SMTP provider IDs: CVE-2026-41016, GHSA-x8mh-94wc-33gv Record: https://patchnext.com/advisories/cve-2026-41016 (revision 2, source checked 26 Oct 2026, 13:41 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-smtp 3.0.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-smtp: affected >= 2.0.0, < 3.0.0; fixed in 3.0.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-smtp`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-smtp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x8mh-94wc-33gv (OSV record GHSA-x8mh-94wc-33gv lists affected ranges: PyPI apache-airflow-providers-smtp >=2.0.0 <3.0.0 (fixed)) - Verified: https://github.com/advisories/GHSA-x8mh-94wc-33gv (GitHub-reviewed advisory GHSA-x8mh-94wc-33gv lists affected ranges: PyPI apache-airflow-providers-smtp >=2.0.0 <3.0.0) Commands are suggestions: review each one before running it.
Loading voting…