Skip to content

← Actionable
High, CVSS 7.2

Spring Cloud Config Server Susceptible To TOCTOU Attack

CVE-2026-41002GHSA-86wq-234q-r6wg

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-86wq-234q-r6wg lists affected ranges: Maven org.springframework.cloud:spring-cloud-config-server >=3.1.0 =4.1.0 =4.2.0 =4.3.0 =5.0.0 =3.0.0 <=3.0.7

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.2 · CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:C/C:H/I:H/A:N
EPSS
  • CVE-2026-41002: 0.22% estimated exploitation activity in the next 30 days; percentile 12.65 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The base directory (spring.cloud.config.server.git.basedir) used by the Spring Cloud Config Server to clone Git repositories to is susceptible to time-of-check-time-of-use (TOCTOU) attacks. - Spring Cloud Config 3.0.x: affected from 3.0.0 through 3.0.7 (inclusive); no open-source upgrade available. - Spring Cloud Config 3.1.x: affected from 3.1.0 through 3.1.13 (inclusive); no open-source upgrade available. - Spring Cloud Config 4.1.x: affected from 4.1.0 through 4.1.9 (inclusive); no open-source upgrade available. - Spring Cloud Config 4.2.x: affected from 4.2.0 through 4.2.6 (inclusive); no open-source upgrade available. - Spring Cloud Config 4.3.x: affected from 4.3.0 through 4.3.2 (inclusive); upgrade to 4.3.3 or greater. - Spring Cloud Config 5.0.x: affected from 5.0.0 through 5.0.2 (inclusive); upgrade to 5.0.3 or greater.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-86wq-234q-r6wg

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41002

Advisory: Spring Cloud Config Server Susceptible To TOCTOU Attack
IDs: CVE-2026-41002, GHSA-86wq-234q-r6wg
Record: https://patchnext.com/advisories/cve-2026-41002 (revision 1, source checked 26 Oct 2026, 16:53 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework.cloud:spring-cloud-config-server 5.0.3, 4.3.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.cloud:spring-cloud-config-server: affected >= 3.1.0, <= 3.1.13; >= 4.1.0, <= 4.1.9; >= 4.2.0, <= 4.2.6; >= 4.3.0, <= 4.3.2; >= 5.0.0, <= 5.0.2; >= 3.0.0, <= 3.0.7; fixed in 4.3.3, 5.0.3

## Suggested inspection (read-only)
- Maven org.springframework.cloud:spring-cloud-config-server: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.cloud:spring-cloud-config-server.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-86wq-234q-r6wg (GitHub-reviewed advisory GHSA-86wq-234q-r6wg lists affected ranges: Maven org.springframework.cloud:spring-cloud-config-server >=3.1.0 =4.1.0 =4.2.0 =4.3.0 =5.0.0 =3.0.0 <=3.0.7)

Commands are suggestions: review each one before running it.

Loading voting…