Skip to content

← Actionable
Low, CVSS 3.7

Spring Web Services: WSS4J validation does not use configured replay cache

CVE-2026-41000GHSA-8qq9-r6cc-qjv9

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
3.7 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N
EPSS
  • CVE-2026-41000: 0.22% estimated exploitation activity in the next 30 days; percentile 13.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Wss4jSecurityInterceptor did not consistently wire Apache WSS4J ReplayCache instances into RequestData for validation-time checks. As a result, protections against replay of UsernameToken nonces and creation timestamps, Timestamp elements, and certain SAML one-time-use semantics could be ineffective even when operators configured a replay cache on the interceptor. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-8qq9-r6cc-qjv9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-41000

Advisory: Spring Web Services: WSS4J validation does not use configured replay cache
IDs: CVE-2026-41000, GHSA-8qq9-r6cc-qjv9
Record: https://patchnext.com/advisories/cve-2026-41000 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Low (CVSS 3.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: org.springframework.ws:spring-ws-security 5.0.2, 4.1.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.springframework.ws:spring-ws-security: affected >= 5.0.0, <= 5.0.1; >= 4.1.0, <= 4.1.3; >= 4.0.0, <= 4.0.18; >= 3.1.0, <= 3.1.8; fixed in 4.1.4, 5.0.2

## Suggested inspection (read-only)
- Maven org.springframework.ws:spring-ws-security: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.springframework.ws:spring-ws-security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-8qq9-r6cc-qjv9 (GitHub-reviewed advisory GHSA-8qq9-r6cc-qjv9 lists affected ranges: Maven org.springframework.ws:spring-ws-security >=5.0.0 =4.1.0 =4.0.0 =3.1.0 <=3.1.8)

Commands are suggestions: review each one before running it.

Loading voting…