Spring Web Services: Wss4jSecurityInterceptor disables WS-I BSP validation by default
CVE-2026-40994GHSA-gg9r-wr4p-w63h
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.springframework.ws:spring-ws-security
- Affected
- >= 5.0.0, <= 5.0.1>= 4.1.0, <= 4.1.3>= 4.0.0, <= 4.0.18>= 3.1.0, <= 3.1.8
- Fixed in
- 4.1.4, 5.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-gg9r-wr4p-w63h lists affected ranges: Maven org.springframework.ws:spring-ws-security >=5.0.0 =4.1.0 =4.0.0 =3.1.0 <=3.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.2 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:H/A:N
- EPSS
- CVE-2026-40994: 0.23% estimated exploitation activity in the next 30 days; percentile 13.84 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Wss4jSecurityInterceptor initialized its BSP (WS-I Basic Security Profile) compliance flag so that inbound validation disabled WSS4J BSP enforcement on RequestData. Services that validate WS-Security on the network could therefore accept messages that violate BSP rules, weakening protocol-level checks. Affected versions: Spring Web Services 5.0.0 through 5.0.1; 4.1.0 through 4.1.3; 4.0.0 through 4.0.18; 3.1.0 through 3.1.8.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-gg9r-wr4p-w63h
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40994 Advisory: Spring Web Services: Wss4jSecurityInterceptor disables WS-I BSP validation by default IDs: CVE-2026-40994, GHSA-gg9r-wr4p-w63h Record: https://patchnext.com/advisories/cve-2026-40994 (revision 1, source checked 26 Oct 2026, 16:55 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.2) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.springframework.ws:spring-ws-security 5.0.2, 4.1.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.springframework.ws:spring-ws-security: affected >= 5.0.0, <= 5.0.1; >= 4.1.0, <= 4.1.3; >= 4.0.0, <= 4.0.18; >= 3.1.0, <= 3.1.8; fixed in 4.1.4, 5.0.2 ## Suggested inspection (read-only) - Maven org.springframework.ws:spring-ws-security: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.springframework.ws:spring-ws-security. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-gg9r-wr4p-w63h (GitHub-reviewed advisory GHSA-gg9r-wr4p-w63h lists affected ranges: Maven org.springframework.ws:spring-ws-security >=5.0.0 =4.1.0 =4.0.0 =3.1.0 <=3.1.8) Commands are suggestions: review each one before running it.
Loading voting…