Skip to content

← Actionable
High, CVSS 7.5

Micrometer HTTP server instrumentations DoS

CVE-2026-40984GHSA-g3pr-3p32-fp23

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-g3pr-3p32-fp23 lists affected ranges: Maven io.micrometer:micrometer-core >=1.16.0 =1.15.0 =1.14.0 =1.10.0 =0 =1.16.0 =1.15.0 =1.14.0 =0 =1.16.0 =1.15.0 =1.14.0 =0 <=1.13.15

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40984: 0.79% estimated exploitation activity in the next 30 days; percentile 56.38 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

In Micrometer, it is possible for a user to provide specially crafted HTTP requests that may cause a denial-of-service (DoS) condition. Affected versions: micrometer-core 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18; 1.9.0 through 1.9.17. micrometer-jetty11 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18. micrometer-jetty12 1.16.0 through 1.16.5; 1.15.0 through 1.15.11; 1.14.0 through 1.14.15; 1.13.0 through 1.13.18.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g3pr-3p32-fp23

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40984

Advisory: Micrometer HTTP server instrumentations DoS
IDs: CVE-2026-40984, GHSA-g3pr-3p32-fp23
Record: https://patchnext.com/advisories/cve-2026-40984 (revision 1, source checked 26 Oct 2026, 16:55 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: io.micrometer:micrometer-jetty11 1.16.6, 1.15.12; io.micrometer:micrometer-core 1.16.6, 1.15.12; io.micrometer:micrometer-jetty12 1.16.6, 1.15.12. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.micrometer:micrometer-jetty11: affected >= 1.16.0, <= 1.16.5; >= 1.15.0, <= 1.15.11; >= 1.14.0, <= 1.14.14; <= 1.13.15; fixed in 1.15.12, 1.16.6
- Maven io.micrometer:micrometer-core: affected >= 1.16.0, <= 1.16.5; >= 1.15.0, <= 1.15.11; >= 1.14.0, <= 1.14.14; >= 1.10.0, <= 1.13.15; <= 1.9.17; fixed in 1.15.12, 1.16.6
- Maven io.micrometer:micrometer-jetty12: affected >= 1.16.0, <= 1.16.5; >= 1.15.0, <= 1.15.11; >= 1.14.0, <= 1.14.14; <= 1.13.15; fixed in 1.15.12, 1.16.6

## Suggested inspection (read-only)
- Maven io.micrometer:micrometer-jetty11: check the installed version with your package manager.
- Maven io.micrometer:micrometer-core: check the installed version with your package manager.
- Maven io.micrometer:micrometer-jetty12: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.micrometer:micrometer-jetty11, io.micrometer:micrometer-core, io.micrometer:micrometer-jetty12.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g3pr-3p32-fp23 (GitHub-reviewed advisory GHSA-g3pr-3p32-fp23 lists affected ranges: Maven io.micrometer:micrometer-core >=1.16.0 =1.15.0 =1.14.0 =1.10.0 =0 =1.16.0 =1.15.0 =1.14.0 =0 =1.16.0 =1.15.0 =1.14.0 =0 <=1.13.15)

Commands are suggestions: review each one before running it.

Loading voting…