apache-airflow-providers-keycloak: Missing OAuth 2.0 State and PKCE Enables Login CSRF and Session Fixation
CVE-2026-40948GHSA-5w6h-pjw6-wvc6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (apache-airflow-providers-keycloak 0.7.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI apache-airflow-providers-keycloak
- Affected
- >= 0.0.1, < 0.7.0
- Fixed in
- 0.7.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5w6h-pjw6-wvc6 lists affected ranges: PyPI apache-airflow-providers-keycloak >=0.0.1 <0.7.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5w6h-pjw6-wvc6 lists affected ranges: PyPI apache-airflow-providers-keycloak >=0.0.1 <0.7.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 5.4 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-40948: 0.40% estimated exploitation activity in the next 30 days; percentile 34.70 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Keycloak authentication manager in apache-airflow-providers-keycloak did not generate or validate the OAuth 2.0 state parameter on the login / login-callback flow, and did not use PKCE. An attacker with a Keycloak account in the same realm could deliver a crafted callback URL to a victim's browser and cause the victim to be logged into the attacker's Airflow session (login-CSRF / session fixation), where any credentials the victim subsequently stored in Airflow Connections would be harvestable by the attacker. Users are advised to upgrade apache-airflow-providers-keycloak to 0.7.0 or later.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-5w6h-pjw6-wvc6
- Revision 1 · created ·
Published from osv record GHSA-5w6h-pjw6-wvc6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40948 Advisory: apache-airflow-providers-keycloak: Missing OAuth 2.0 State and PKCE Enables Login CSRF and Session Fixation IDs: CVE-2026-40948, GHSA-5w6h-pjw6-wvc6 Record: https://patchnext.com/advisories/cve-2026-40948 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 5.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: apache-airflow-providers-keycloak 0.7.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI apache-airflow-providers-keycloak: affected >= 0.0.1, < 0.7.0; fixed in 0.7.0 ## Suggested inspection (read-only) - `python -m pip show apache-airflow-providers-keycloak`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on apache-airflow-providers-keycloak. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5w6h-pjw6-wvc6 (OSV record GHSA-5w6h-pjw6-wvc6 lists affected ranges: PyPI apache-airflow-providers-keycloak >=0.0.1 <0.7.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5w6h-pjw6-wvc6 (GitHub-reviewed advisory GHSA-5w6h-pjw6-wvc6 lists affected ranges: PyPI apache-airflow-providers-keycloak >=0.0.1 <0.7.0) Commands are suggestions: review each one before running it.
Loading voting…