Oxia's TLS CA certificate chain validation fails with multi-certificate PEM bundles
CVE-2026-40944GHSA-7jrq-q4pq-rhm6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/oxia-db/oxia 0.16.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- <= 0.16.1
- Fixed in
- 0.16.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-7jrq-q4pq-rhm6 lists affected ranges: Go github.com/oxia-db/oxia >=0 <=0.16.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.0 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2026-40944: 0.16% estimated exploitation activity in the next 30 days; percentile 5.25 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The trustedCertPool() function in the TLS configuration only parses the first PEM block from CA certificate files. When a CA bundle contains multiple certificates (e.g., intermediate + root CA), only the first certificate is loaded. This silently breaks certificate chain validation for mTLS. Impact In deployments using mTLS with certificate chains (intermediate CA + root CA bundles), legitimate clients with properly chained certificates are rejected with x509: certificate signed by unknown authority. This degrades the security posture by making mTLS unusable with standard CA chain configurations, potentially forcing operators to disable client certificate verification. All versions using TLS with trustedCaFile configuration are affected. Details In common/security/tls.go, the trustedCertPool() method calls pem.Decode() only once, processing a single PEM block. The remaining bytes (containing additional certificates) are silently discarded. Additionally, the error return from…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-7jrq-q4pq-rhm6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40944 Advisory: Oxia's TLS CA certificate chain validation fails with multi-certificate PEM bundles IDs: CVE-2026-40944, GHSA-7jrq-q4pq-rhm6 Record: https://patchnext.com/advisories/cve-2026-40944 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.0) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/oxia-db/oxia 0.16.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/oxia-db/oxia: affected <= 0.16.1; fixed in 0.16.2 ## Suggested inspection (read-only) - Go github.com/oxia-db/oxia: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/oxia-db/oxia. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-7jrq-q4pq-rhm6 (GitHub-reviewed advisory GHSA-7jrq-q4pq-rhm6 lists affected ranges: Go github.com/oxia-db/oxia >=0 <=0.16.1) Commands are suggestions: review each one before running it.
Loading voting…