Jupyter Server's Authentication Cookies Remain Valid After Password Reset and Server Restart
CVE-2026-40934GHSA-5mrq-x3x5-8v8f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (jupyter-server 2.18.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI jupyter-server
- Affected
- <= 2.17.0
- Fixed in
- 2.18.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-5mrq-x3x5-8v8f lists affected ranges: PyPI jupyter-server >=0 <2.18.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5mrq-x3x5-8v8f lists affected ranges: PyPI jupyter-server >=0 <=2.17.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 7.6 · CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-40934: 0.33% estimated exploitation activity in the next 30 days; percentile 26.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A persistent cookie secret vulnerability allows authenticated users to maintain indefinite access even after password changes. The cookie secret used to sign authentication cookies is stored in a permanent file (~/.local/share/jupyter/runtime/jupytercookiesecret) that is never automatically rotated or cleared, allowing stolen or compromised cookies to remain valid indefinitely regardless of password resets. PoC - Start a Jupyter server with password authentication: jupyter server password, jupyter server - Log in with the password and capture the authentication cookie (e.g., just login with a browser). - Change the password to revoke access: jupyter server password - Restart the server - Use the old stolen cookie = remains valid and provides full authenticated access. Impact - All jupyter-server deployments using password authentication where security incidents may occur - Multi-user systems where one user's compromised session should be revocable by administrators - Shared…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-5mrq-x3x5-8v8f
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-5mrq-x3x5-8v8f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40934 Advisory: Jupyter Server's Authentication Cookies Remain Valid After Password Reset and Server Restart IDs: CVE-2026-40934, GHSA-5mrq-x3x5-8v8f Record: https://patchnext.com/advisories/cve-2026-40934 (revision 3, source checked 26 Oct 2026, 13:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: jupyter-server 2.18.0. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI jupyter-server: affected <= 2.17.0; fixed in 2.18.0 ## Suggested inspection (read-only) - `python -m pip show jupyter-server`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on jupyter-server. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-5mrq-x3x5-8v8f (OSV record GHSA-5mrq-x3x5-8v8f lists affected ranges: PyPI jupyter-server >=0 <2.18.0 (fixed)) - Verified: https://github.com/advisories/GHSA-5mrq-x3x5-8v8f (GitHub-reviewed advisory GHSA-5mrq-x3x5-8v8f lists affected ranges: PyPI jupyter-server >=0 <=2.17.0) Commands are suggestions: review each one before running it.
Loading voting…