Skip to content

← Actionable
High, CVSS 8.4amended

Complete Bypass of CVE-2026-24884 Patch via Git-Delivered Symlink Poisoning in compressing

CVE-2026-40931GHSA-4c3q-x735-j3r5

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (compressing 2.1.1, 1.10.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm compressing

    Affected
    >= 2.0.0, <= 2.1.0<= 1.10.4
    Fixed in
    1.10.5, 2.1.1

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.4 · CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-40931: 0.26% estimated exploitation activity in the next 30 days; percentile 17.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

1. Executive Summary This report documents a critical security research finding in the compressing npm package (specifically tested on the latest v2.1.0). The core vulnerability is a Partial Fix Bypass of CVE-2026-24884. The current patch relies on a purely logical string validation within the isPathWithinParent utility. This check verifies if a resolved path string starts with the destination directory string but fails to account for the actual filesystem state. By exploiting this "Logical vs. Physical" divergence, we successfully bypassed the security check using a Directory Poisoning technique (pre-existing symbolic links). Key Findings: Vulnerable Component: lib/utils.js - isPathWithinParent() Flaw Type: Incomplete validation (lack of recursive lstat checks). Primary Attack Vector: Supply Chain via Git Clone The attack requires zero victim interaction beyond standard developer workflow (git clone + node app.js). Git natively preserves symlinks during clone, automatically…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-4c3q-x735-j3r5

  2. Revision 1 · created ·

    Published from osv record GHSA-4c3q-x735-j3r5

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40931

Advisory: Complete Bypass of CVE-2026-24884 Patch via Git-Delivered Symlink Poisoning in compressing
IDs: CVE-2026-40931, GHSA-4c3q-x735-j3r5
Record: https://patchnext.com/advisories/cve-2026-40931 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.4)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: compressing 2.1.1, 1.10.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm compressing: affected >= 2.0.0, <= 2.1.0; <= 1.10.4; fixed in 1.10.5, 2.1.1

## Suggested inspection (read-only)
- `npm ls compressing --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on compressing.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-4c3q-x735-j3r5 (OSV record GHSA-4c3q-x735-j3r5 lists affected ranges: npm compressing >=2.0.0 =0 <1.10.5 (fixed))
- Verified: https://github.com/advisories/GHSA-4c3q-x735-j3r5 (GitHub-reviewed advisory GHSA-4c3q-x735-j3r5 lists affected ranges: npm compressing >=2.0.0 =0 <=1.10.4)

Commands are suggestions: review each one before running it.

Loading voting…