Apache Artemis has an Incorrect Authorization issue
CVE-2026-40914GHSA-rf99-f9j2-gv3f
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.artemis:artemis-stomp-protocol
- Affected
- >= 2.50.0, <= 2.53.0>= 2.0.0, <= 2.44.0
- Fixed in
- 2.54.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rf99-f9j2-gv3f lists affected ranges: Maven org.apache.artemis:artemis-stomp-protocol >=2.50.0 =2.0.0 <=2.44.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- EPSS
- CVE-2026-40914: 0.37% estimated exploitation activity in the next 30 days; percentile 31.18 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
A vulnerability exists in Apache Artemis whereby an application using the STOMP protocol with security credentials that grant either the consume or send permission on an address can augment the routing-type supported by that address even if said user doesn't have the createAddress permission for that particular address. A user could successfully send a message to an address or consume a message from a queue with a routing-type not supported by the corresponding address when that operation should actually be rejected on the basis that the user doesn't have permission to change the routing-type of the address. Even though the user was already granted permission to send and/or consume messages, they should not be able to augment the routing-type of the address without the createAddress permission. This issue affects Apache Artemis: from 2.50.0 through 2.53.0; Apache ActiveMQ Artemis: from 2.0.0 through 2.44.0. Users are recommended to upgrade to version 2.54.0, which fixes the issue.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rf99-f9j2-gv3f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40914 Advisory: Apache Artemis has an Incorrect Authorization issue IDs: CVE-2026-40914, GHSA-rf99-f9j2-gv3f Record: https://patchnext.com/advisories/cve-2026-40914 (revision 1, source checked 26 Oct 2026, 16:54 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: org.apache.artemis:artemis-stomp-protocol 2.54.0. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.artemis:artemis-stomp-protocol: affected >= 2.50.0, <= 2.53.0; >= 2.0.0, <= 2.44.0; fixed in 2.54.0 ## Suggested inspection (read-only) - Maven org.apache.artemis:artemis-stomp-protocol: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.artemis:artemis-stomp-protocol. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rf99-f9j2-gv3f (GitHub-reviewed advisory GHSA-rf99-f9j2-gv3f lists affected ranges: Maven org.apache.artemis:artemis-stomp-protocol >=2.50.0 =2.0.0 <=2.44.0) Commands are suggestions: review each one before running it.
Loading voting…