frp has an authentication bypass in HTTP vhost routing when routeByHTTPUser is used for access control
CVE-2026-40910GHSA-pq96-pwvg-vrr9
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/fatedier/frp 0.68.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
- Affected
- >= 0.43.0, <= 0.68.0
- Fixed in
- 0.68.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pq96-pwvg-vrr9 lists affected ranges: Go github.com/fatedier/frp >=0.43.0 <=0.68.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:L/A:N
- EPSS
- CVE-2026-40910: 0.27% estimated exploitation activity in the next 30 days; percentile 19.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary frp contains an authentication bypass in the HTTP vhost routing path when routeByHTTPUser is used as part of access control. In proxy-style requests, the routing logic uses the username from Proxy-Authorization to select the routeByHTTPUser backend, while the access control check uses credentials from the regular Authorization header. As a result, an attacker who can reach the HTTP vhost entrypoint and knows or can guess the protected routeByHTTPUser value may access a backend protected by httpUser / httpPassword even with an incorrect Proxy-Authorization password. This issue affects deployments that explicitly use routeByHTTPUser. It does not affect ordinary HTTP proxies that do not use this feature. Details The issue is in pkg/util/vhost/http.go. In proxy-style requests using an absolute URI, the routing path extracts the username from Proxy-Authorization and stores it as the request HTTPUser, which is then used for routeByHTTPUser route selection. More specifically,…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pq96-pwvg-vrr9
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40910 Advisory: frp has an authentication bypass in HTTP vhost routing when routeByHTTPUser is used for access control IDs: CVE-2026-40910, GHSA-pq96-pwvg-vrr9 Record: https://patchnext.com/advisories/cve-2026-40910 (revision 1, source checked 26 Oct 2026, 15:19 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: github.com/fatedier/frp 0.68.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Go github.com/fatedier/frp: affected >= 0.43.0, <= 0.68.0; fixed in 0.68.1 ## Suggested inspection (read-only) - Go github.com/fatedier/frp: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on github.com/fatedier/frp. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pq96-pwvg-vrr9 (GitHub-reviewed advisory GHSA-pq96-pwvg-vrr9 lists affected ranges: Go github.com/fatedier/frp >=0.43.0 <=0.68.0) Commands are suggestions: review each one before running it.
Loading voting…