Skip to content

← Actionable
High, CVSS 7.5

PhpSpreadsheet has CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions

CVE-2026-40902GHSA-7c6m-4442-2x6m

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.7.0, 3.10.5, 2.4.5, 2.1.16, 1.30.4), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 4.0.0, <= 5.6.0>= 3.3.0, <= 3.10.4>= 2.2.0, <= 2.4.4>= 2.0.0, <= 2.1.15<= 1.30.3
    Fixed in
    2.4.5, 1.30.4, 3.10.5, 2.1.16, 5.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40902: 0.40% estimated exploitation activity in the next 30 days; percentile 33.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The XLSX reader's ColumnAndRowAttributes::readRowAttributes() method reads row numbers from XML attributes without validating them against the spreadsheet maximum row limit (AddressRange::MAXROW = 1,048,576). An attacker can craft a minimal XLSX file (~1.6KB) containing a <row r="999999999"/ element that inflates cachedHighestRow to 999,999,999, causing any subsequent row iteration to attempt ~1 billion loop cycles and exhaust CPU resources. Details In src/PhpSpreadsheet/Reader/Xlsx/ColumnAndRowAttributes.php at line 216, the row index is cast directly from XML without bounds checking: This value flows through setRowAttributes() (line 126) → $this-worksheet-getRowDimension($rowNumber) (line 60), which updates the cached highest row in Worksheet.php:1348: The inflated cachedHighestRow is then returned by getHighestRow() (line 1099) and used as the default end bound in RowIterator::resetEnd() (RowIterator.php:86): Notably, column attributes already have equivalent validation at…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7c6m-4442-2x6m

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40902

Advisory: PhpSpreadsheet has CPU Denial of Service via Unbounded Row Number in XLSX Row Dimensions
IDs: CVE-2026-40902, GHSA-7c6m-4442-2x6m
Record: https://patchnext.com/advisories/cve-2026-40902 (revision 1, source checked 26 Oct 2026, 14:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.7.0, 3.10.5, 2.4.5, 2.1.16, 1.30.4. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, <= 5.6.0; >= 3.3.0, <= 3.10.4; >= 2.2.0, <= 2.4.4; >= 2.0.0, <= 2.1.15; <= 1.30.3; fixed in 2.4.5, 1.30.4, 3.10.5, 2.1.16, 5.7.0

## Suggested inspection (read-only)
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7c6m-4442-2x6m (GitHub-reviewed advisory GHSA-7c6m-4442-2x6m lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.3)

Commands are suggestions: review each one before running it.

Loading voting…