follow-redirects leaks Custom Authentication Headers to Cross-Domain Redirect Targets
CVE-2026-40895GHSA-r4q5-vmmm-2653
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (follow-redirects 1.16.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm follow-redirects
- Affected
- < 1.16.0
- Fixed in
- 1.16.0
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-r4q5-vmmm-2653 lists affected ranges: npm follow-redirects >=0 <1.16.0 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r4q5-vmmm-2653 lists affected ranges: npm follow-redirects >=0 <=1.15.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-40895: 0.49% estimated exploitation activity in the next 30 days; percentile 41.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary When an HTTP request follows a cross-domain redirect (301/302/307/308), `follow-redirects` only strips `authorization`, `proxy-authorization`, and `cookie` headers (matched by regex at index.js:469-476). Any custom authentication header (e.g., `X-API-Key`, `X-Auth-Token`, `Api-Key`, `Token`) is forwarded verbatim to the redirect target. Since `follow-redirects` is the redirect-handling dependency for axios (105K+ stars), this vulnerability affects the entire axios ecosystem.
Affected Code `index.js`, lines 469-476: ```javascript if (redirectUrl.protocol !== currentUrlParts.protocol && redirectUrl.protocol !== "https:" || redirectUrl.host !== currentHost && !isSubdomain(redirectUrl.host, currentHost)) { removeMatchingHeaders(/^(?:(?:proxy-)?authorization|cookie)$/i, this._options.headers); } ``` The regex only matches `authorization`, `proxy-authorization`, and `cookie`. Custom headers like `X-API-Key` are not matched.
Attack Scenario 1. App uses axios with custom…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 5 · amended ·
Amended from osv record GHSA-r4q5-vmmm-2653
- Revision 4 · amended ·
Amended from ghsa record GHSA-r4q5-vmmm-2653
- Revision 3 · amended ·
Amended from ghsa record GHSA-r4q5-vmmm-2653
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-r4q5-vmmm-2653
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40895 Advisory: follow-redirects leaks Custom Authentication Headers to Cross-Domain Redirect Targets IDs: CVE-2026-40895, GHSA-r4q5-vmmm-2653 Record: https://patchnext.com/advisories/cve-2026-40895 (revision 5, source checked 3 Nov 2026, 06:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: follow-redirects 1.16.0. A vendor fix does not mean a deployment is fixed. ## Affected components - npm follow-redirects: affected < 1.16.0; fixed in 1.16.0 ## Suggested inspection (read-only) - `npm ls follow-redirects --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on follow-redirects. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-r4q5-vmmm-2653 (OSV record GHSA-r4q5-vmmm-2653 lists affected ranges: npm follow-redirects >=0 <1.16.0 (fixed)) - Verified: https://github.com/advisories/GHSA-r4q5-vmmm-2653 (GitHub-reviewed advisory GHSA-r4q5-vmmm-2653 lists affected ranges: npm follow-redirects >=0 <=1.15.11) Commands are suggestions: review each one before running it.
Loading voting…