@vendure/core has a SQL Injection vulnerability
CVE-2026-40887GHSA-9pp3-53p2-ww9v
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@vendure/core 3.6.2, 3.5.7, 2.3.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @vendure/core
- Affected
- >= 3.0.0, < 3.5.7>= 3.6.0, < 3.6.2>= 1.7.4, < 2.3.4
- Fixed in
- 3.6.2, 2.3.4, 3.5.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9pp3-53p2-ww9v lists affected ranges: npm @vendure/core >=3.0.0 =3.6.0 =1.7.4 <2.3.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-9pp3-53p2-ww9v lists affected ranges: npm @vendure/core >=3.0.0 =3.6.0 =1.7.4 <2.3.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
- EPSS
- CVE-2026-40887: 1.76% estimated exploitation activity in the next 30 days; percentile 78.05 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary An unauthenticated SQL injection vulnerability exists in the Vendure Shop API. A user-controlled query string parameter is interpolated directly into a raw SQL expression without parameterization or validation, allowing an attacker to execute arbitrary SQL against the database. This affects all supported database backends (PostgreSQL, MySQL/MariaDB, SQLite). The Admin API is also affected, though exploitation there requires authentication. Affected versions - @vendure/core < 2.3.4 - @vendure/core = 3.0.0, < 3.5.7 - @vendure/core = 3.6.0, < 3.6.2 Note: versions 2.3.4 and above in the 2.x line are patched. There were no 2.4.x or 2.x releases between 2.3.x and 3.0.0. Patched versions - @vendure/core 2.3.4 - @vendure/core 3.5.7 - @vendure/core 3.6.2 Details In ProductService.findOneBySlug, the request context's languageCode value is interpolated into a SQL CASE expression via a JavaScript template literal: TypeORM has no opportunity to parameterize this value because it is…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-9pp3-53p2-ww9v
- Revision 2 · amended ·
Amended from osv record GHSA-9pp3-53p2-ww9v
- Revision 1 · created ·
Published from ghsa record GHSA-9pp3-53p2-ww9v
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40887 Advisory: @vendure/core has a SQL Injection vulnerability IDs: CVE-2026-40887, GHSA-9pp3-53p2-ww9v Record: https://patchnext.com/advisories/cve-2026-40887 (revision 3, source checked 26 Oct 2026, 12:51 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @vendure/core 3.6.2, 3.5.7, 2.3.4. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @vendure/core: affected >= 3.0.0, < 3.5.7; >= 3.6.0, < 3.6.2; >= 1.7.4, < 2.3.4; fixed in 3.6.2, 2.3.4, 3.5.7 ## Suggested inspection (read-only) - `npm ls @vendure/core --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @vendure/core. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9pp3-53p2-ww9v (GitHub-reviewed advisory GHSA-9pp3-53p2-ww9v lists affected ranges: npm @vendure/core >=3.0.0 =3.6.0 =1.7.4 <2.3.4) - Verified: https://osv.dev/vulnerability/GHSA-9pp3-53p2-ww9v (OSV record GHSA-9pp3-53p2-ww9v lists affected ranges: npm @vendure/core >=3.0.0 =3.6.0 =1.7.4 <2.3.4 (fixed)) Commands are suggestions: review each one before running it.
Loading voting…