Skip to content

← Actionable
High, CVSS 7.6

OpenRemote has XXE in Velbus Asset Import

CVE-2026-40882GHSA-g24f-mgc3-jwwc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (io.openremote:openremote-manager 1.22.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.6 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:L
EPSS
  • CVE-2026-40882: 0.26% estimated exploitation activity in the next 30 days; percentile 17.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The Velbus asset import path parses attacker-controlled XML without explicit XXE hardening. An authenticated user who can call the import endpoint may trigger XML external entity processing, which can lead to server-side file disclosure and SSRF. The target file must be less than 1023 characters. Details Velbus import uses DocumentBuilderFactory.newInstance().newDocumentBuilder().parse(...) on untrusted XML input, without explicit safeguards to disable DTD/external entities. Expanded Caption content is propagated into created asset names: PoC 1. Log in to a realm with a user that can call Velbus asset import. 2. Create/select a Velbus TCP Agent in that same realm. 3. Send POST /api/{realm}/agent/assetImport/{agentId} with a Velbus project XML payload and compare behavior against a baseline import file. 3. Save the below code as a xxe.xml and upload to Setup under https://localhost/manager/?realm=<YOURREALM#/assets/false/<ASSETID. Chnage the file:///etc/passwd to another file…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-g24f-mgc3-jwwc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40882

Advisory: OpenRemote has XXE in Velbus Asset Import
IDs: CVE-2026-40882, GHSA-g24f-mgc3-jwwc
Record: https://patchnext.com/advisories/cve-2026-40882 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: io.openremote:openremote-manager 1.22.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven io.openremote:openremote-manager: affected <= 1.21.0; fixed in 1.22.0

## Suggested inspection (read-only)
- Maven io.openremote:openremote-manager: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on io.openremote:openremote-manager.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-g24f-mgc3-jwwc (GitHub-reviewed advisory GHSA-g24f-mgc3-jwwc lists affected ranges: Maven io.openremote:openremote-manager >=0 <=1.21.0)

Commands are suggestions: review each one before running it.

Loading voting…