Skip to content

← Actionable
High, CVSS 7.5amended

Nest Affected by DoS via Recursive handleData in JsonSocket (TCP Transport)

CVE-2026-40879GHSA-hpwf-8g29-85qm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nestjs/microservices 11.1.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40879: 0.33% estimated exploitation activity in the next 30 days; percentile 26.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Attacker sends many small, valid JSON messages in one TCP frame → handleData() recurses once per message; buffer shrinks each call → maxBufferSize is never reached; call stack overflows instead → A ~47 KB payload is sufficient to trigger RangeError Patches Fixed in @nestjs/microservices@11.1.19 References Discovered by https://github.com/hwpark6804-gif

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-hpwf-8g29-85qm

  2. Revision 1 · created ·

    Published from osv record GHSA-hpwf-8g29-85qm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40879

Advisory: Nest Affected by DoS via Recursive handleData in JsonSocket (TCP Transport)
IDs: CVE-2026-40879, GHSA-hpwf-8g29-85qm
Record: https://patchnext.com/advisories/cve-2026-40879 (revision 2, source checked 26 Oct 2026, 12:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: @nestjs/microservices 11.1.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm @nestjs/microservices: affected <= 11.1.18; fixed in 11.1.19

## Suggested inspection (read-only)
- `npm ls @nestjs/microservices --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on @nestjs/microservices.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-hpwf-8g29-85qm (OSV record GHSA-hpwf-8g29-85qm lists affected ranges: npm @nestjs/microservices >=0 <11.1.19 (fixed))
- Verified: https://github.com/advisories/GHSA-hpwf-8g29-85qm (GitHub-reviewed advisory GHSA-hpwf-8g29-85qm lists affected ranges: npm @nestjs/microservices >=0 <=11.1.18)

Commands are suggestions: review each one before running it.

Loading voting…