Skip to content

← Actionable
High, CVSS 7.5amended

PhpSpreadsheet has CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader

CVE-2026-40863GHSA-84wq-86v6-x5j6

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpoffice/phpspreadsheet 5.7.0, 3.10.5, 2.4.5, 2.1.16, 1.30.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist phpoffice/phpspreadsheet

    Affected
    >= 4.0.0, < 5.7.0>= 3.3.0, < 3.10.5>= 2.2.0, < 2.4.5>= 2.0.0, < 2.1.16< 1.30.6
    Fixed in
    2.4.5, 3.10.5, 1.30.6, 2.1.16, 5.7.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
7.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
EPSS
  • CVE-2026-40863: 0.40% estimated exploitation activity in the next 30 days; percentile 33.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary The SpreadsheetML XML reader (`Reader\Xml`) does not validate the `ss:Index` row attribute against the maximum allowed row count (`AddressRange::MAX_ROW = 1,048,576`). An attacker can craft a SpreadsheetML XML file with `ss:Index="999999999"` on a ` ` element, which inflates the internal `cachedHighestRow` to ~1 billion. Any subsequent call to `getRowIterator()` without an explicit end row will attempt to iterate ~1 billion rows, causing CPU exhaustion and denial of service.

Details In `src/PhpSpreadsheet/Reader/Xml.php`, the `loadSpreadsheetFromFile` method processes ` ` elements: ```php // Xml.php:397-402 if (isset($row_ss['Index'])) { $rowID = (int) $row_ss['Index']; // No validation against MAX_ROW } if (isset($row_ss['Hidden'])) { $rowVisible = ((string) $row_ss['Hidden']) !== '1'; $spreadsheet->getActiveSheet()->getRowDimension($rowID)->setVisible($rowVisible); } ``` The `$rowID` value read from `ss:Index` is cast to int with no upper bound check. It is then…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from osv record GHSA-84wq-86v6-x5j6

  2. Revision 2 · amended ·

    Amended from ghsa record GHSA-84wq-86v6-x5j6

  3. Revision 1 · created ·

    Published from ghsa record GHSA-84wq-86v6-x5j6

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40863

Advisory: PhpSpreadsheet has CPU Denial of Service via Unbounded Row Index in SpreadsheetML XML Reader
IDs: CVE-2026-40863, GHSA-84wq-86v6-x5j6
Record: https://patchnext.com/advisories/cve-2026-40863 (revision 3, source checked 27 Oct 2026, 06:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 7.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: phpoffice/phpspreadsheet 5.7.0, 3.10.5, 2.4.5, 2.1.16, 1.30.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist phpoffice/phpspreadsheet: affected >= 4.0.0, < 5.7.0; >= 3.3.0, < 3.10.5; >= 2.2.0, < 2.4.5; >= 2.0.0, < 2.1.16; < 1.30.6; fixed in 2.4.5, 3.10.5, 1.30.6, 2.1.16, 5.7.0

## Suggested inspection (read-only)
- Packagist phpoffice/phpspreadsheet: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on phpoffice/phpspreadsheet.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-84wq-86v6-x5j6 (GitHub-reviewed advisory GHSA-84wq-86v6-x5j6 lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.3)
- Verified: https://github.com/advisories/GHSA-84wq-86v6-x5j6 (GitHub-reviewed advisory GHSA-84wq-86v6-x5j6 lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <=1.30.5)
- Verified: https://osv.dev/vulnerability/GHSA-84wq-86v6-x5j6 (OSV record GHSA-84wq-86v6-x5j6 lists affected ranges: Packagist phpoffice/phpspreadsheet >=4.0.0 =3.3.0 =2.2.0 =2.0.0 =0 <1.30.6 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…