OpenStack Keystone: LDAP identity backend does not convert enabled attribute to boolean
CVE-2026-40683GHSA-pfx2-9x9m-7ghx
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 28.0.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI keystone
- Affected
- < 28.0.1
- Fixed in
- 28.0.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-pfx2-9x9m-7ghx lists affected ranges: PyPI keystone >=0 <28.0.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pfx2-9x9m-7ghx lists affected ranges: PyPI keystone >=0 <28.0.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 7.7 · CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H
- EPSS
- CVE-2026-40683: 0.34% estimated exploitation activity in the next 30 days; percentile 27.20 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
In OpenStack Keystone before 28.0.1, the LDAP identity backend does not convert the user enabled attribute to a boolean when the userenabledinvert configuration option is False (the default). The ldaprestomodel method in the UserApi class only performed string-to-boolean conversion when userenabledinvert was True. When False, the raw string value from LDAP (e.g., "FALSE") was used directly. Since non-empty strings are truthy in Python, users marked as disabled in LDAP were treated as enabled by Keystone, allowing them to authenticate and perform actions. All deployments using the LDAP identity backend without userenabledinvert=True or userenabledemulation are affected.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-pfx2-9x9m-7ghx
- Revision 1 · created ·
Published from osv record GHSA-pfx2-9x9m-7ghx
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40683 Advisory: OpenStack Keystone: LDAP identity backend does not convert enabled attribute to boolean IDs: CVE-2026-40683, GHSA-pfx2-9x9m-7ghx Record: https://patchnext.com/advisories/cve-2026-40683 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 7.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: keystone 28.0.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI keystone: affected < 28.0.1; fixed in 28.0.1 ## Suggested inspection (read-only) - `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on keystone. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-pfx2-9x9m-7ghx (OSV record GHSA-pfx2-9x9m-7ghx lists affected ranges: PyPI keystone >=0 <28.0.1 (fixed)) - Verified: https://github.com/advisories/GHSA-pfx2-9x9m-7ghx (GitHub-reviewed advisory GHSA-pfx2-9x9m-7ghx lists affected ranges: PyPI keystone >=0 <28.0.1) Commands are suggestions: review each one before running it.
Loading voting…