Skip to content

← Actionable
Medium, CVSS 5.5amended

BentoML has Information Disclosure in bentoml build via symlink traversal in the build context

CVE-2026-40610GHSA-mcfx-4vc6-qgxv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (bentoml 1.4.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI bentoml

    Affected
    <= 1.4.38
    Fixed in
    1.4.39

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.5 · CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
EPSS
  • CVE-2026-40610: 0.28% estimated exploitation activity in the next 30 days; percentile 21.00 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary BentoML's bentoml build packaging workflow follows attacker-controlled symlinks inside the build context and copies the referenced file contents into the generated Bento artifact. If a victim builds an untrusted repository or other attacker-supplied build context, the attacker can place a symlink such as loot.txt - /tmp/outside-marker.txt or a link to a more sensitive local file. When bentoml build runs, BentoML dereferences the symlink and packages the target file contents into the Bento. The leaked file can then propagate further through export, push, or containerization workflows. Details The vulnerable code walks files under the build context and copies each matched entry into the Bento source directory: There is no validation that the resolved path of srcfile remains inside ctxpath before shutil.copy dereferences the source path. As a result, a repository-controlled symlink can cross the trust boundary from attacker-controlled repository content to developer/CI host…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mcfx-4vc6-qgxv

  2. Revision 1 · created ·

    Published from osv record GHSA-mcfx-4vc6-qgxv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40610

Advisory: BentoML has Information Disclosure in `bentoml build` via symlink traversal in the build context
IDs: CVE-2026-40610, GHSA-mcfx-4vc6-qgxv
Record: https://patchnext.com/advisories/cve-2026-40610 (revision 2, source checked 26 Oct 2026, 13:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: bentoml 1.4.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI bentoml: affected <= 1.4.38; fixed in 1.4.39

## Suggested inspection (read-only)
- `python -m pip show bentoml`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on bentoml.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mcfx-4vc6-qgxv (OSV record GHSA-mcfx-4vc6-qgxv lists affected ranges: PyPI bentoml >=0 <1.4.39 (fixed))
- Verified: https://github.com/advisories/GHSA-mcfx-4vc6-qgxv (GitHub-reviewed advisory GHSA-mcfx-4vc6-qgxv lists affected ranges: PyPI bentoml >=0 <=1.4.38)

Commands are suggestions: review each one before running it.

Loading voting…