Skip to content

← Actionable
Medium, CVSS 4.8amended

mitmproxy has an LDAP Injection

CVE-2026-40606GHSA-527g-3w9m-29hv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (mitmproxy 12.2.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI mitmproxy

    Affected
    <= 12.2.1
    Fixed in
    12.2.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
EPSS
  • CVE-2026-40606: 0.17% estimated exploitation activity in the next 30 days; percentile 5.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact In mitmproxy 12.2.1 and below, the builtin LDAP proxy authentication does not correctly sanitize the username when querying the LDAP server. This allows a malicious client to bypass authentication. Only mitmproxy instances using the proxyauth option with LDAP are affected. This option is not enabled by default. Patches The vulnerability has been fixed in mitmproxy 12.2.2 and above. Acknowledgements We thank Yue (Knox) Liu (@yueyueL) for responsibly disclosing this vulnerability to the mitmproxy team. Timeline - 2025-12-08: Received initial report. - 2025-12-09: Verified report and confirmed receipt. - 2026-01-02: Informed researcher that patch will be part of the next regular patch release. - 2026-04-12: Published patch release and advisory.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-527g-3w9m-29hv

  2. Revision 1 · created ·

    Published from osv record GHSA-527g-3w9m-29hv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40606

Advisory: mitmproxy has an LDAP Injection
IDs: CVE-2026-40606, GHSA-527g-3w9m-29hv
Record: https://patchnext.com/advisories/cve-2026-40606 (revision 2, source checked 26 Oct 2026, 13:44 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 4.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: mitmproxy 12.2.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI mitmproxy: affected <= 12.2.1; fixed in 12.2.2

## Suggested inspection (read-only)
- `python -m pip show mitmproxy`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on mitmproxy.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-527g-3w9m-29hv (OSV record GHSA-527g-3w9m-29hv lists affected ranges: PyPI mitmproxy >=0 <12.2.2 (fixed))
- Verified: https://github.com/advisories/GHSA-527g-3w9m-29hv (GitHub-reviewed advisory GHSA-527g-3w9m-29hv lists affected ranges: PyPI mitmproxy >=0 <=12.2.1)

Commands are suggestions: review each one before running it.

Loading voting…