Skip to content

← Actionable
Critical, CVSS 9.1

OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing

CVE-2026-40575GHSA-7x63-xv5r-3p2x

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (github.com/oauth2-proxy/oauth2-proxy/v7 7.15.2), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
EPSS
  • CVE-2026-40575: 0.48% estimated exploitation activity in the next 30 days; percentile 41.26 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact A configuration-dependent authentication bypass exists in OAuth2 Proxy. Deployments are affected when all of the following are true: OAuth2 Proxy is configured with --reverse-proxy and at least one rule is defined with --skipauthroutes or the legacy --skip-auth-regex OAuth2 Proxy may trust a client-supplied X-Forwarded-Uri header when --reverse-proxy is enabled and --skip-auth-route or --skip-auth-regex is configured. An attacker can spoof this header so OAuth2 Proxy evaluates authentication and skip-auth rules against a different path than the one actually sent to the upstream application. This can result in an unauthenticated remote attacker bypassing authentication and accessing protected routes without a valid session. Patches This issue is addressed as part of the newly introduced --trusted-proxy-ip flag in v7.15.2. If you leave it unset, OAuth2 Proxy will continue to trust ALL source IPs (0.0.0.0/0) for backwards compatibility, which means a client may still be able to…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7x63-xv5r-3p2x

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40575

Advisory: OAuth2 Proxy has an Authentication Bypass via X-Forwarded-Uri Header Spoofing
IDs: CVE-2026-40575, GHSA-7x63-xv5r-3p2x
Record: https://patchnext.com/advisories/cve-2026-40575 (revision 1, source checked 26 Oct 2026, 15:27 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: github.com/oauth2-proxy/oauth2-proxy/v7 7.15.2. A vendor fix does not mean a deployment is fixed.

## Affected components
- Go github.com/oauth2-proxy/oauth2-proxy/v7: affected >= 7.5.0, < 7.15.2; fixed in 7.15.2

## Suggested inspection (read-only)
- Go github.com/oauth2-proxy/oauth2-proxy/v7: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on github.com/oauth2-proxy/oauth2-proxy/v7.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7x63-xv5r-3p2x (GitHub-reviewed advisory GHSA-7x63-xv5r-3p2x lists affected ranges: Go github.com/oauth2-proxy/oauth2-proxy/v7 >=7.5.0 <7.15.2)

Commands are suggestions: review each one before running it.

Loading voting…