Apache Storm Prometheus Reporter vulnerable to Improper Certificate Validation via Global SSL Context Downgrade
CVE-2026-40557GHSA-82fm-wpc2-5pmp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.storm:storm-metrics-prometheus 2.8.7), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.storm:storm-metrics-prometheus
- Affected
- >= 2.6.3, < 2.8.7
- Fixed in
- 2.8.7
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-82fm-wpc2-5pmp lists affected ranges: Maven org.apache.storm:storm-metrics-prometheus >=2.6.3 <2.8.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.8 · CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N
- EPSS
- CVE-2026-40557: 0.19% estimated exploitation activity in the next 30 days; percentile 9.08 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Improper Certificate Validation via Global SSL Context Downgrade in Apache Storm Prometheus Reporter Versions Affected: from 2.6.3 to 2.8.6 Description: In production deployments where an administrator enables storm.daemon.metrics.reporter.plugin.prometheus.skiptlsvalidation (by default it is disabled) intending to affect only the Prometheus reporter, the undocumented global side effect creates an attack surface across every TLS-protected communication channel in the Storm daemon. The PrometheusPreparableReporter class implements an INSECURETRUSTMANAGER that accepts all SSL certificates without validation, with empty checkClientTrusted and checkServerTrusted methods. Most critically, when the storm.daemon.metrics.reporter.plugin.prometheus.skiptlsvalidation configuration option is enabled (default = disabled) for HTTPS Prometheus PushGateway connections, the INSECURECONNECTIONFACTORY calls SSLContext.setDefault(sslContext), which globally replaces the JVM's default SSL context rather…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-82fm-wpc2-5pmp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40557 Advisory: Apache Storm Prometheus Reporter vulnerable to Improper Certificate Validation via Global SSL Context Downgrade IDs: CVE-2026-40557, GHSA-82fm-wpc2-5pmp Record: https://patchnext.com/advisories/cve-2026-40557 (revision 1, source checked 26 Oct 2026, 16:45 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.storm:storm-metrics-prometheus 2.8.7. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.storm:storm-metrics-prometheus: affected >= 2.6.3, < 2.8.7; fixed in 2.8.7 ## Suggested inspection (read-only) - Maven org.apache.storm:storm-metrics-prometheus: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.storm:storm-metrics-prometheus. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-82fm-wpc2-5pmp (GitHub-reviewed advisory GHSA-82fm-wpc2-5pmp lists affected ranges: Maven org.apache.storm:storm-metrics-prometheus >=2.6.3 <2.8.7) Commands are suggestions: review each one before running it.
Loading voting…