gdown Affected by Arbitrary File Write via Path Traversal in gdown.extractall
CVE-2026-40491GHSA-76hw-p97h-883f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (gdown 5.2.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI gdown
- Affected
- <= 5.2.1
- Fixed in
- 5.2.2
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-76hw-p97h-883f lists affected ranges: PyPI gdown >=0 <5.2.2 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-76hw-p97h-883f lists affected ranges: PyPI gdown >=0 <=5.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 6.5 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N
- EPSS
- CVE-2026-40491: 0.57% estimated exploitation activity in the next 30 days; percentile 47.50 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The gdown library (tested on v5.2.1) is vulnerable to a Path Traversal attack within its extractall functionality. When extracting a maliciously crafted ZIP or TAR archive, the library fails to sanitize or validate the filenames of the archive members. This allow files to be written outside the intended destination directory, potentially leading to arbitrary file overwrite and Remote Code Execution (RCE). Details The vulnerability exists in gdown/extractall.py within the extractall() function. The function takes an archive path and a destination directory (to), then calls the underlying extractall() method of Python's tarfile or zipfile modules without validating whether the archive members stay within the to boundary. Vulnerable Code: Even on modern Python versions (3.12+), if the filter parameter is not explicitly set or if the library's wrapper logic bypasses modern protections, path traversal remains possible as demonstrated in the PoC. PoC Steps to Reproduce 1. Create…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-76hw-p97h-883f
- Revision 1 · created ·
Published from osv record GHSA-76hw-p97h-883f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40491 Advisory: gdown Affected by Arbitrary File Write via Path Traversal in gdown.extractall IDs: CVE-2026-40491, GHSA-76hw-p97h-883f Record: https://patchnext.com/advisories/cve-2026-40491 (revision 2, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.5) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: gdown 5.2.2. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI gdown: affected <= 5.2.1; fixed in 5.2.2 ## Suggested inspection (read-only) - `python -m pip show gdown`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on gdown. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-76hw-p97h-883f (OSV record GHSA-76hw-p97h-883f lists affected ranges: PyPI gdown >=0 <5.2.2 (fixed)) - Verified: https://github.com/advisories/GHSA-76hw-p97h-883f (GitHub-reviewed advisory GHSA-76hw-p97h-883f lists affected ranges: PyPI gdown >=0 <=5.2.1) Commands are suggestions: review each one before running it.
Loading voting…