Skip to content

← Actionable
High, CVSS 8.8

Camel-MINA Vulnerable to Deserialization of Untrusted Data

CVE-2026-40473GHSA-vpr3-2659-rw55

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-mina 4.20.0, 4.18.2, 4.14.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
8.8 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-40473: 1.19% estimated exploitation activity in the next 30 days; percentile 67.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The camel-mina component's MinaConverter.toObjectInput(IoBuffer) type converter wraps an IoBuffer in a java.io.ObjectInputStream without applying any ObjectInputFilter or class-loading restrictions. When a Camel route uses camel-mina as a TCP or UDP consumer and requests conversion to ObjectInput (for example via getBody(ObjectInput.class) or @Body ObjectInput), an attacker sending a crafted serialized Java object over the network to the MINA consumer port can trigger arbitrary code execution in the context of the application during readObject(). This issue affects Apache Camel: from 3.0.0 before 4.14.6, from 4.15.0 before 4.18.2, from 4.19.0 before 4.20.0. Users are recommended to upgrade to version 4.20.0, which fixes the issue. If users are on the 4.14.x LTS releases stream, then they are suggested to upgrade to 4.14.6. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.2.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vpr3-2659-rw55

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40473

Advisory: Camel-MINA Vulnerable to Deserialization of Untrusted Data
IDs: CVE-2026-40473, GHSA-vpr3-2659-rw55
Record: https://patchnext.com/advisories/cve-2026-40473 (revision 1, source checked 26 Oct 2026, 16:45 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-mina 4.20.0, 4.18.2, 4.14.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-mina: affected >= 3.0.0, < 4.14.6; >= 4.15.0, < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.14.6, 4.20.0

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-mina: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-mina.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vpr3-2659-rw55 (GitHub-reviewed advisory GHSA-vpr3-2659-rw55 lists affected ranges: Maven org.apache.camel:camel-mina >=3.0.0 =4.15.0 =4.19.0 <4.20.0)

Commands are suggestions: review each one before running it.

Loading voting…