Skip to content

← Actionable
Critical, CVSS 9.9

Apache Camel has an incomplete fix for CVE-2025-27636

CVE-2026-40453GHSA-jg2m-9x48-3gvj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-jms 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-sjms 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-google-pubsub 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-coap 4.20.0, 4.18.2, 4.14.6), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-jg2m-9x48-3gvj lists affected ranges: Maven org.apache.camel:camel-coap >=3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 <4.20.0

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.9 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
EPSS
  • CVE-2026-40453: 2.10% estimated exploitation activity in the next 30 days; percentile 81.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The fix for CVE-2025-27636 added setLowerCase(true) to HttpHeaderFilterStrategy so that case-variant header names such as 'CAmelExecCommandExecutable' are filtered out alongside 'CamelExecCommandExecutable'. The same setLowerCase(true) call was not applied to five non-HTTP HeaderFilterStrategy implementations: JmsHeaderFilterStrategy and ClassicJmsHeaderFilterStrategy in camel-jms, SjmsHeaderFilterStrategy in camel-sjms, CoAPHeaderFilterStrategy in camel-coap, and GooglePubsubHeaderFilterStrategy in camel-google-pubsub. Because those strategies use case-sensitive String.startsWith('Camel'/'camel') filtering while the Camel Exchange stores headers in a case-insensitive map, an attacker with JMS (or equivalent) producer access to the broker consumed by a Camel route can inject case-variant Camel internal headers, which are then resolved by downstream components such as camel-exec and camel-file using their canonical casing. This enables remote code execution and arbitrary file write on…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-jg2m-9x48-3gvj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40453

Advisory: Apache Camel has an incomplete fix for CVE-2025-27636
IDs: CVE-2026-40453, GHSA-jg2m-9x48-3gvj
Record: https://patchnext.com/advisories/cve-2026-40453 (revision 1, source checked 26 Oct 2026, 16:56 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-jms 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-sjms 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-google-pubsub 4.20.0, 4.18.2, 4.14.6; org.apache.camel:camel-coap 4.20.0, 4.18.2, 4.14.6. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-jms: affected >= 3.0.0, < 4.14.6; >= 4.15.0, < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.14.6, 4.20.0
- Maven org.apache.camel:camel-sjms: affected >= 3.0.0, < 4.14.6; >= 4.15.0, < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.14.6, 4.20.0
- Maven org.apache.camel:camel-google-pubsub: affected >= 3.0.0, < 4.14.6; >= 4.15.0, < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.14.6, 4.20.0
- Maven org.apache.camel:camel-coap: affected >= 3.0.0, < 4.14.6; >= 4.15.0, < 4.18.2; >= 4.19.0, < 4.20.0; fixed in 4.18.2, 4.14.6, 4.20.0

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-jms: check the installed version with your package manager.
- Maven org.apache.camel:camel-sjms: check the installed version with your package manager.
- Maven org.apache.camel:camel-google-pubsub: check the installed version with your package manager.
- Maven org.apache.camel:camel-coap: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-jms, org.apache.camel:camel-sjms, org.apache.camel:camel-google-pubsub, org.apache.camel:camel-coap.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-jg2m-9x48-3gvj (GitHub-reviewed advisory GHSA-jg2m-9x48-3gvj lists affected ranges: Maven org.apache.camel:camel-coap >=3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 =3.0.0 =4.15.0 =4.19.0 <4.20.0)

Commands are suggestions: review each one before running it.

Loading voting…