Skip to content

← Actionable
Medium, CVSS 5.3amended

python-multipart affected by Denial of Service via large multipart preamble or epilogue data

CVE-2026-40347GHSA-mj87-hwqh-73pj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (python-multipart 0.0.26), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
5.3 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
EPSS
  • CVE-2026-40347: 0.35% estimated exploitation activity in the next 30 days; percentile 28.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Summary A denial of service vulnerability exists when parsing crafted multipart/form-data requests with large preamble or epilogue sections. Details Two inefficient multipart parsing paths could be abused with attacker-controlled input. Before the first multipart boundary, the parser handled leading CR and LF bytes inefficiently while searching for the start of the first part. After the closing boundary, the parser continued processing trailing epilogue data instead of discarding it immediately. As a result, parsing time could grow with the size of crafted data placed before the first boundary or after the closing boundary. Impact An attacker can send oversized malformed multipart bodies that consume excessive CPU time during request parsing, reducing request-handling capacity and delaying legitimate requests. This issue degrades availability but does not typically result in a complete denial of service for the entire application. Mitigation Upgrade to version 0.0.26 or later, which…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-mj87-hwqh-73pj

  2. Revision 1 · created ·

    Published from osv record GHSA-mj87-hwqh-73pj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40347

Advisory: python-multipart affected by Denial of Service via large multipart preamble or epilogue data
IDs: CVE-2026-40347, GHSA-mj87-hwqh-73pj
Record: https://patchnext.com/advisories/cve-2026-40347 (revision 2, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 5.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: python-multipart 0.0.26. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI python-multipart: affected < 0.0.26; fixed in 0.0.26

## Suggested inspection (read-only)
- `python -m pip show python-multipart`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on python-multipart.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-mj87-hwqh-73pj (OSV record GHSA-mj87-hwqh-73pj lists affected ranges: PyPI python-multipart >=0 <0.0.26 (fixed))
- Verified: https://github.com/advisories/GHSA-mj87-hwqh-73pj (GitHub-reviewed advisory GHSA-mj87-hwqh-73pj lists affected ranges: PyPI python-multipart >=0 <0.0.26)

Commands are suggestions: review each one before running it.

Loading voting…