NocoBase has SSRF in Workflow HTTP Request and Custom Request Plugins
CVE-2026-40346GHSA-mvvv-v22x-xqwp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (@nocobase/plugin-workflow-request 2.0.37), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
npm @nocobase/plugin-workflow-request
- Affected
- < 2.0.37
- Fixed in
- 2.0.37
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-mvvv-v22x-xqwp lists affected ranges: npm @nocobase/plugin-workflow-request >=0 <2.0.37 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mvvv-v22x-xqwp lists affected ranges: npm @nocobase/plugin-workflow-request >=0 <2.0.37
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.4 · CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:N · score source
- EPSS
- CVE-2026-40346: 0.38% estimated exploitation activity in the next 30 days; percentile 32.53 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary NocoBase's workflow HTTP request plugin and custom request action plugin make server-side HTTP requests to user-provided URLs without any SSRF protection. An authenticated user can access internal network services, cloud metadata endpoints, and localhost. Vulnerable Code 1. Workflow HTTP Request Plugin packages/plugins/@nocobase/plugin-workflow-request/src/server/RequestInstruction.ts lines 117-128: The url at line 98 comes directly from user workflow configuration with only whitespace trimming. 2. Custom Request Action Plugin packages/plugins/@nocobase/plugin-action-custom-request/src/server/actions/send.ts lines 172-198: Missing Protections - No request-filtering-agent or SSRF library (confirmed via grep across entire codebase) - No private IP range filtering - No cloud metadata endpoint blocking - No URL scheme validation - No DNS rebinding protection Attack Scenario 1. Authenticated user creates a workflow with HTTP Request node 2. Sets URL to…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-mvvv-v22x-xqwp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-mvvv-v22x-xqwp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40346 Advisory: NocoBase has SSRF in Workflow HTTP Request and Custom Request Plugins IDs: CVE-2026-40346, GHSA-mvvv-v22x-xqwp Record: https://patchnext.com/advisories/cve-2026-40346 (revision 3, source checked 26 Oct 2026, 12:52 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.4) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: @nocobase/plugin-workflow-request 2.0.37. A vendor fix does not mean a deployment is fixed. ## Affected components - npm @nocobase/plugin-workflow-request: affected < 2.0.37; fixed in 2.0.37 ## Suggested inspection (read-only) - `npm ls @nocobase/plugin-workflow-request --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on @nocobase/plugin-workflow-request. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-mvvv-v22x-xqwp (OSV record GHSA-mvvv-v22x-xqwp lists affected ranges: npm @nocobase/plugin-workflow-request >=0 <2.0.37 (fixed)) - Verified: https://github.com/advisories/GHSA-mvvv-v22x-xqwp (GitHub-reviewed advisory GHSA-mvvv-v22x-xqwp lists affected ranges: npm @nocobase/plugin-workflow-request >=0 <2.0.37) Commands are suggestions: review each one before running it.
Loading voting…