Skip to content

← Actionable
Critical, CVSS 9.1

ChilliCream GraphQL Platform: Utf8GraphQLParser Stack Overflow via Deeply Nested GraphQL Documents

CVE-2026-40324GHSA-qr3m-xw4c-jqw3

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (hotchocolate.language 15.1.14, 14.3.1, 13.9.16, 12.22.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • NuGet hotchocolate.language

    Affected
    < 12.22.7>= 13.0.0, < 13.9.16>= 14.0.0, < 14.3.1>= 15.0.0, < 15.1.14
    Fixed in
    13.9.16, 15.1.14, 14.3.1, 12.22.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H
EPSS
  • CVE-2026-40324: 0.90% estimated exploitation activity in the next 30 days; percentile 59.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Impact Hot Chocolate's Utf8GraphQLParser is a recursive descent parser with no recursion depth limit. A crafted GraphQL document with deeply nested selection sets, object values, list values, or list types can trigger a StackOverflowException on payloads as small as 40 KB. Because StackOverflowException is uncatchable in .NET (since .NET 2.0), the entire worker process is terminated immediately. All in-flight HTTP requests, background IHostedService tasks, and open WebSocket subscriptions on that worker are dropped. The orchestrator (Kubernetes, IIS, etc.) must restart the process. This occurs before any validation rules run — MaxExecutionDepth, complexity analyzers, persisted query allow-lists, and custom IDocumentValidatorRule implementations cannot intercept the crash because Utf8GraphQLParser.Parse is invoked before validation. The existing MaxAllowedFields=2048 limit does not help because the crashing payloads contain very few fields. Severity: Critical (9.1) —…

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qr3m-xw4c-jqw3

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40324

Advisory: ChilliCream GraphQL Platform: Utf8GraphQLParser Stack Overflow via Deeply Nested GraphQL Documents
IDs: CVE-2026-40324, GHSA-qr3m-xw4c-jqw3
Record: https://patchnext.com/advisories/cve-2026-40324 (revision 1, source checked 26 Oct 2026, 17:04 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: hotchocolate.language 15.1.14, 14.3.1, 13.9.16, 12.22.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- NuGet hotchocolate.language: affected < 12.22.7; >= 13.0.0, < 13.9.16; >= 14.0.0, < 14.3.1; >= 15.0.0, < 15.1.14; fixed in 13.9.16, 15.1.14, 14.3.1, 12.22.7

## Suggested inspection (read-only)
- NuGet hotchocolate.language: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on hotchocolate.language.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qr3m-xw4c-jqw3 (GitHub-reviewed advisory GHSA-qr3m-xw4c-jqw3 lists affected ranges: NuGet hotchocolate.language >=0 =13.0.0 =14.0.0 =15.0.0 <15.1.14)

Commands are suggestions: review each one before running it.

Loading voting…