SP1 V6 Recursion Circuit Row-Count Binding Gap
CVE-2026-40323GHSA-63x8-x938-vx33
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sp1_prover 6.1.0; sp1_recursion_circuit 6.1.0; sp1_sdk 6.1.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
crates.io sp1_prover
- Affected
- >= 6.0.0, <= 6.0.2
- Fixed in
- 6.1.0
crates.io sp1_recursion_circuit
- Affected
- >= 6.0.0, <= 6.0.2
- Fixed in
- 6.1.0
crates.io sp1_sdk
- Affected
- >= 6.0.0, <= 6.0.2
- Fixed in
- 6.1.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-63x8-x938-vx33 lists affected ranges: crates.io sp1_sdk >=6.0.0 =6.0.0 =6.0.0 <=6.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.9 · CVSS:4.0/AV:N/AC:H/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N · score source
- EPSS
- CVE-2026-40323: 0.19% estimated exploitation activity in the next 30 days; percentile 9.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary A soundness vulnerability in the SP1 V6 recursive shard verifier allows a malicious prover to construct a recursive proof from a shard proof that the native verifier would reject. - Affected versions: = 6.0.0, <= 6.0.2 - Not affected: SP1 V5 (all versions) - Severity: High Details Background The recursive shard verifier circuit verifies shard proofs inside a recursive proof. Each shard proof includes a jagged PCS opening, which binds trace-shape metadata into a modified commitment and uses that same shape to evaluate the committed polynomials. These two operations must agree on the committed table heights. The Bug In the V6 recursion circuit's jagged verifier, the two checks above are served by separate witnesses: a vector of row counts hashed into the modified commitment (commitment side), and a separate witness of prefix sums derived from row and column counts that drives the jagged polynomial evaluator (evaluation side). The prefix sums are observed within the shard…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-63x8-x938-vx33
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40323 Advisory: SP1 V6 Recursion Circuit Row-Count Binding Gap IDs: CVE-2026-40323, GHSA-63x8-x938-vx33 Record: https://patchnext.com/advisories/cve-2026-40323 (revision 1, source checked 26 Oct 2026, 15:42 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sp1_prover 6.1.0; sp1_recursion_circuit 6.1.0; sp1_sdk 6.1.0. A vendor fix does not mean a deployment is fixed. ## Affected components - crates.io sp1_prover: affected >= 6.0.0, <= 6.0.2; fixed in 6.1.0 - crates.io sp1_recursion_circuit: affected >= 6.0.0, <= 6.0.2; fixed in 6.1.0 - crates.io sp1_sdk: affected >= 6.0.0, <= 6.0.2; fixed in 6.1.0 ## Suggested inspection (read-only) - crates.io sp1_prover: check the installed version with your package manager. - crates.io sp1_recursion_circuit: check the installed version with your package manager. - crates.io sp1_sdk: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sp1_prover, sp1_recursion_circuit, sp1_sdk. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-63x8-x938-vx33 (GitHub-reviewed advisory GHSA-63x8-x938-vx33 lists affected ranges: crates.io sp1_sdk >=6.0.0 =6.0.0 =6.0.0 <=6.0.2) Commands are suggestions: review each one before running it.
Loading voting…