PraisonAI: SQLiteConversationStore didn't validate table_prefix when constructing SQL queries
CVE-2026-40315GHSA-x783-xp3g-mqhp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonai 4.5.133), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI praisonai
- Affected
- < 4.5.133
- Fixed in
- 4.5.133
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x783-xp3g-mqhp lists affected ranges: PyPI praisonai >=0 <4.5.133 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x783-xp3g-mqhp lists affected ranges: PyPI praisonai >=0 <4.5.133
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2026-40315: 0.30% estimated exploitation activity in the next 30 days; percentile 22.40 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Summary The tableprefix configuration value is directly used to construct SQL table identifiers without validation. If an attacker controls this value, they can manipulate SQL query structure, leading to unauthorized data access (e.g., reading internal SQLite tables such as sqlitemaster) and tampering with query results. --- Details This allows attackers to inject arbitrary SQL fragments into table identifiers, effectively altering query execution. This occurs because tableprefix is passed from configuration (fromyaml / fromdict) into SQLiteConversationStore and directly concatenated into SQL queries via f-strings: This value is then used in queries such as: Since SQL identifiers cannot be safely parameterized and are not validated, attacker-controlled input can modify SQL query structure. The vulnerability originates from configuration input and propagates through the following flow: Source: config.py (fromyaml / fromdict) accepts external configuration input Propagation: factory.py…
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x783-xp3g-mqhp
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x783-xp3g-mqhp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2026-40315 Advisory: PraisonAI: SQLiteConversationStore didn't validate table_prefix when constructing SQL queries IDs: CVE-2026-40315, GHSA-x783-xp3g-mqhp Record: https://patchnext.com/advisories/cve-2026-40315 (revision 3, source checked 26 Oct 2026, 13:40 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: praisonai 4.5.133. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI praisonai: affected < 4.5.133; fixed in 4.5.133 ## Suggested inspection (read-only) - `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on praisonai. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x783-xp3g-mqhp (OSV record GHSA-x783-xp3g-mqhp lists affected ranges: PyPI praisonai >=0 <4.5.133 (fixed)) - Verified: https://github.com/advisories/GHSA-x783-xp3g-mqhp (GitHub-reviewed advisory GHSA-x783-xp3g-mqhp lists affected ranges: PyPI praisonai >=0 <4.5.133) Commands are suggestions: review each one before running it.
Loading voting…