Skip to content

← Actionable
Critical, CVSS 9.8amended

PraisonAI has critical RCE via type: job workflow YAML

CVE-2026-40288GHSA-vc46-vw85-3wvm

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (praisonaiagents 1.5.140; praisonai 4.5.139), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
9.8 · CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
EPSS
  • CVE-2026-40288: 0.61% estimated exploitation activity in the next 30 days; percentile 49.19 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

praisonai workflow run <file.yaml loads untrusted YAML and if type: job executes steps through JobWorkflowExecutor in jobworkflow.py. This supports: - run: → shell command execution via subprocess.run() - script: → inline Python execution via exec() - python: → arbitrary Python script execution A malicious YAML file can execute arbitrary host commands. Affected Code - workflow.py → actionrun() - jobworkflow.py → execshell(), execinlinepython(), execpythonscript() PoC Create exploit.yaml: Run: Reproduction Steps 1. Save the YAML above as exploit.yaml. 2. Execute praisonai workflow run exploit.yaml. 3. Confirm pwned.txt appears in the working directory. Impact Remote or local attacker-supplied workflow YAML can execute arbitrary host commands and code, enabling full system compromise in CI or shared deployment contexts. Reporter: Lakshmikanthan K (letchupkt)

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vc46-vw85-3wvm

  2. Revision 2 · amended ·

    Amended from osv record GHSA-vc46-vw85-3wvm

  3. Revision 1 · created ·

    Published from ghsa record GHSA-vc46-vw85-3wvm

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2026-40288

Advisory: PraisonAI has critical RCE via `type: job` workflow YAML
IDs: CVE-2026-40288, GHSA-vc46-vw85-3wvm
Record: https://patchnext.com/advisories/cve-2026-40288 (revision 3, source checked 26 Oct 2026, 13:40 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.8)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: praisonaiagents 1.5.140; praisonai 4.5.139. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI praisonaiagents: affected <= 1.5.139; fixed in 1.5.140
- PyPI praisonai: affected <= 4.5.138; fixed in 4.5.139

## Suggested inspection (read-only)
- `python -m pip show praisonaiagents`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show praisonai`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on praisonaiagents, praisonai.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vc46-vw85-3wvm (GitHub-reviewed advisory GHSA-vc46-vw85-3wvm lists affected ranges: PyPI praisonaiagents >=0 =0 <=4.5.138)
- Verified: https://osv.dev/vulnerability/GHSA-vc46-vw85-3wvm (OSV record GHSA-vc46-vw85-3wvm lists affected ranges: PyPI praisonaiagents >=0 =0 <4.5.139 (fixed))

Commands are suggestions: review each one before running it.

Loading voting…